Bug 755729 - Error message for resize2fs-M needs tweaking
Error message for resize2fs-M needs tweaking
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: libguestfs (Show other bugs)
unspecified
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Richard W.M. Jones
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-21 16:38 EST by Alex Beamish
Modified: 2012-05-03 09:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-03 09:47:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Beamish 2011-11-21 16:38:50 EST
Description of problem:

Running the command 'resize2fs-M /dev/vda1'

at the guestfish prompt produces the error message

  libguestfs: error: resize2fs_M: resize2fs 1.41.14 (22-Dec-2010)
  Please run 'e2fsck -f /dev/vda1' first.

The actual command that should be run is one without the space between 'e2fsck' and '-f', in other words, 'e2fsck-f'.


Version-Release number of selected component (if applicable):

guestfish 1.14.0


How reproducible:

I saw it once -- since this an error message, I imagine it's reproducible.

Steps to Reproduce:
1. Add a VDI to guestfish, run it.
2. resize2fs-M /dev/vda1
3. Observe error reproduced above.


Actual results:

As above.


Expected results:

  libguestfs: error: resize2fs_M: resize2fs 1.41.14 (22-Dec-2010)
  Please run 'e2fsck-f /dev/vda1' first.


Additional info:
Comment 1 Richard W.M. Jones 2011-11-21 17:08:30 EST
We'd need to capture the error message (which comes from the
resize2fs utility itself) and rewrite it in the daemon.
Comment 2 Wanlong Gao 2012-01-13 20:40:05 EST
sent the fix patch to upstream:
https://www.redhat.com/archives/libguestfs/2012-January/msg00102.html
Comment 3 Richard W.M. Jones 2012-01-14 03:18:34 EST
Thanks, this is upstream now:

https://github.com/libguestfs/libguestfs/commit/0eaf06e673833bc25673d5c3d2487fffae310285
Comment 4 Richard W.M. Jones 2012-03-09 13:15:46 EST
Reopening, see:

https://www.redhat.com/archives/libguestfs/2012-March/msg00049.html
Comment 5 Richard W.M. Jones 2012-05-03 09:47:37 EDT
OK, the upstream policy is not to rewrite error messages,
because whenever we try to do it, it's bitten us.

If necessary we'll document them, which is what I have
done here:
https://www.redhat.com/archives/libguestfs/2012-March/msg00054.html

Note You need to log in before you can comment on or make changes to this bug.