Bug 75586 - FTP install fails on disconnect
FTP install fails on disconnect
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 19:55 EDT by bill parducci
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-09 17:23:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description bill parducci 2002-10-09 19:55:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2a) Gecko/20020910

Description of problem:
anaconda terminates if it receives a 'connection refused' from ftp site on net
install.  since installs over ftp are typically done in our shop by mounting a
cd for direct access, inetd/ftpd must be stopped to swap CDs. as late as version
7.3 anaconda would retry the request until the ftp server was restarted on the
remote end.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.english install of 8.0
2. ftp install
3. start/stop remote ftp daemon  when files on first cd have been installed.	

Actual Results:  anaconda crashed, checking alternative output (alt-F3) showed
that after a series of 'file not found' (normal) entries, it reported a
'connection refused' and aborted.

Expected Results:  should have tried to reconnect (as was the case in versions
thru 7.x)

Additional info:

don't think this is system specific or specfic to upgrade vs. install.

the biggest problem is that i now have a half upgraded server that i have to try
to repair.
Comment 1 Jeremy Katz 2002-10-14 11:01:54 EDT
This is due to changes in how urllib in python 2.2 handles errors as opposed to
urllib in python 1.5.
Comment 2 Jeremy Katz 2003-01-08 17:01:05 EST
This is handled sanely in our current codebase (we retry five times, if it
fails, pop up a dialog saying there might be a problem, but let you retry)
Comment 3 Mike McLean 2003-01-09 17:23:54 EST
fix confirmed

Note You need to log in before you can comment on or make changes to this bug.