Bug 75590 - Program crashes unless shadow passwds are used.
Summary: Program crashes unless shadow passwds are used.
Status: CLOSED DUPLICATE of bug 68245
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-users   
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 00:25 UTC by akonstam
Modified: 2008-05-01 15:38 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 14:54:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description akonstam 2002-10-10 00:25:23 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When you run redhat-config-users when you are using non MD% passwds and not
using shadow passwds the program crashes with the error:
/usr/share/redhat-config-users/redhat-config-users: line 4:  1363 Segmentation
fault      /usr/bin/python2.2 /usr/share/redhat-config-users/redhat-config-users.py


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1 run: redhat-config-users
2.
3.
	

Actual Results:  /usr/share/redhat-config-users/redhat-config-users: line 4: 
1363 Segmentation fault      /usr/bin/python2.2
/usr/share/redhat-config-users/redhat-config-users.py


Expected Results:  Opens gui window to allow adding and removing users

Additional info:

If you run redhat-config users with shadow passwds the gui opens and users
records can be manipulated but you get a warning:
(redhat-config-users.py:1007): Gtk-WARNING **:
/usr/lib/gtk-2.0/2.0.0/engines/libmetal.so: undefined symbol:
gtk_toggle_button_get_type
Which is also incorrect because the gtk_toggle_button_get_type does exist in the
library libmetal.so:

Comment 1 akonstam 2002-10-10 00:35:59 UTC
Tammy Fox asked me to include my /etc/sysconfig/i18n file which I forgot to do;
LANG="en_US.UTF-8"
SUPPORTED="en_US.UTF-8:en_US:en"
SYSFONT="latarcyrheb-sun16"

Comment 2 akonstam 2002-10-10 13:59:08 UTC
I now find that the warning:
redhat-config-users.py:1007): Gtk-WARNING **:
/usr/lib/gtk-2.0/2.0.0/engines/libmetal.so: undefined symbol:
gtk_toggle_button_get_type
occurs only when you login as a normal user and then su- to root

If you login as root then run redhat-config-users the warning is not generated.
I hope all this information is usefull because I find it confusing.

Comment 3 Tammy Fox 2002-10-10 14:54:44 UTC
/etc/sysconfig/i18n is supposed to be included on a different bug. Ignore
it for this one.

Comment 4 Brent Fox 2002-10-14 16:43:32 UTC

*** This bug has been marked as a duplicate of 68245 ***


Note You need to log in before you can comment on or make changes to this bug.