Bug 75595 - mc does not display correctly in rxvt
mc does not display correctly in rxvt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: slang (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 22:14 EDT by Radu Cornea
Modified: 2015-01-07 19:00 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-09 22:57:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radu Cornea 2002-10-09 22:14:49 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021009
Phoenix/0.3

Description of problem:
mc from RH 8.0 does not display correctly the lines in rxvt (it uses the wrong
set of characters). It works in xterm.
If I use the binary from RH 7.3, everything is fine. This is what ldd sais on both:

mc (8.0):
        libslang-utf8.so.1 => /usr/lib/libslang-utf8.so.1 (0x40021000)
        libgpm.so.1 => /usr/lib/libgpm.so.1 (0x40087000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x4008c000)
        libext2fs.so.2 => /lib/libext2fs.so.2 (0x400b2000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x400ca000)
        libtermcap.so.2 => /lib/libtermcap.so.2 (0x400cc000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        libdl.so.2 => /lib/libdl.so.2 (0x400d1000)
        libm.so.6 => /lib/i686/libm.so.6 (0x400d4000)
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x400f6000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)


mc (RH 7.3):
        libgpm.so.1 => /usr/lib/libgpm.so.1 (0x40021000)
        libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x40027000)
        libext2fs.so.2 => /lib/libext2fs.so.2 (0x4004d000)
        libcom_err.so.2 => /lib/libcom_err.so.2 (0x40065000)
        libc.so.6 => /lib/i686/libc.so.6 (0x42000000)
        libncurses.so.5 => /usr/lib/libncurses.so.5 (0x40067000)
        /lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

The --version option returns:

for mc (RH 8.0):
GNU Midnight Commander 4.5.55
Edition: text mode
Virtual File System: tarfs, extfs, ftpfs, mcfs, undelfs
With builtin Editor
Using system-installed S-Lang library with termcap database
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
Using locale "en_US.UTF-8" (from environment variable LANG)

for mc (7.3):
GNU Midnight Commander 4.5.55
Edition: text mode
Virtual File System: tarfs, extfs, ftpfs, mcfs, undelfs
With builtin Editor
Using S-Lang library with terminfo database
With subshell support as default
With support for background operations
With mouse support on xterm and Linux console
Using locale "en_US.UTF-8" (from environment variable LANG)


Given these, I suspect the problem is with the slang library.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install rxvt (from RH 7.3).
2.Run rxvt
3.Run mc in it
	

Actual Results:  The output is totally garbled.

Expected Results:  The lines should be displayed correctly.

Additional info:
Comment 1 Havoc Pennington 2002-10-09 22:32:55 EDT
Moving to slang, if that's the initial guess at the problem.

(The terminals other than gnome-terminal/konsole are pretty much provided
"as-is" though, if it turns out to be an rxvt-specific issue.)
Comment 2 Bill Nottingham 2002-10-09 22:44:25 EDT
Are you running rxvt in a unicode locale? If so, it sort of requires that the
terminal supports unicode.
Comment 3 Radu Cornea 2002-10-09 22:57:48 EDT
I checked the LANG variable and it's defined as "en_US.UTF-8" by default. If I
change it to "en_US.iso885915" or "en", mc works fine in rxvt. So it seems that
the locale was causing the problem. Thanks very much for the help.
Comment 4 Bill Nottingham 2002-10-09 23:05:51 EDT
Yes; this is an issue with rxvt, in that it doesn't handle unicode correctly. As
rxvt is not actually shipped with 8.0, closing this bug.

Note You need to log in before you can comment on or make changes to this bug.