Bug 75596 - USB Support Disabled after Upgrade to 8.0 from 7.3
USB Support Disabled after Upgrade to 8.0 from 7.3
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-09 22:25 EDT by Gerald Cox
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-18 18:01:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output from DMESG and /proc/interrupts (10.37 KB, text/plain)
2002-10-10 13:11 EDT, Gerald Cox
no flags Details
Trace taken after mouse and camera plugged into USB ports. Thanks! (10.16 KB, text/plain)
2002-10-10 14:19 EDT, Gerald Cox
no flags Details
lspci -v with 4 1.1 ports and a 2.0 port (4.74 KB, text/plain)
2002-10-11 16:33 EDT, Pete Zaitcev
no flags Details

  None (edit)
Description Gerald Cox 2002-10-09 22:25:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Upgraded system from 7.3, Logitech Optical USB Scroll mouse which worked fine
under 7.3 no longer functions when USB connected.  Workaround - connect as PS2
device.  Tried to connect several other USB devices, none are detected at boot
up.  USB devices have power after BIOS Post, but are deactivated as soon as the
Kernel selection screen is displayed. Device is autodetected as Generic PS2
Three Button Mouse when connected to PS2 port. USB GRAVIS Gamecontroller no
longer functions.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.System reboot
2.
3.
	

Actual Results:  No USB Devices are detected.  

Expected Results:  USB Devices should be detected and activated.  Mouse worked
perfected as USB Scroll when running 7.3.  Upgrade to 8.0 now only allows device
to work when PS2 connected and then it works only as generic three button, no
scroll functionality.  GAME Controller should be autodetected as under 7.3,
however now no longer functions.

Additional info:

System Motherboard is Gigabyte 7VRXP with AMD 1900XP Processor.
Comment 1 Pete Zaitcev 2002-10-10 12:51:37 EDT
Please attach output of "dmesg" and "cat /proc/interrupts".
PLEASE DO NOT DROP THEM IN THE COMMENT BOX.
Comment 2 Gerald Cox 2002-10-10 13:11:44 EDT
Created attachment 79806 [details]
Output from DMESG and /proc/interrupts
Comment 3 Gerald Cox 2002-10-10 13:13:12 EDT
I've attached the information as requested.  Currently mouse is connected as
PS/2 device.  No USB devices are currently attached to system (since it doesn't
work).  Thanks!
Comment 4 Pete Zaitcev 2002-10-10 13:22:06 EDT
Trace skillfuly taken, thanks. But the objective is to fix the USB,
and for that we need to see how it fails. Can you plug the mouse
back into a USB port and re-take dmesg? No need to reboot.
Comment 5 Gerald Cox 2002-10-10 14:19:12 EDT
Created attachment 79824 [details]
Trace taken after mouse and camera plugged into USB ports.  Thanks!
Comment 6 Pete Zaitcev 2002-10-10 14:55:38 EDT
This bug is worse than I thought, EHCI is busted. Arjan, I'm taking it.
Comment 7 Pete Zaitcev 2002-10-11 16:30:51 EDT
Worked offline with the customer, removed ehci-hcd from the
configuration (commented alias usb-controller in modules.conf),
so the box now works in USB 1.1 mode.

Investigating if 2.0 is useful. Motherboard manual:
http://ftp.gigabyte.com.tw/support/user_pdf/e_7vrxp_1101.pdf
Comment 8 Pete Zaitcev 2002-10-11 16:33:00 EDT
Created attachment 80045 [details]
lspci -v with 4 1.1 ports and a 2.0 port
Comment 9 Pete Zaitcev 2002-10-18 18:00:56 EDT
If I read it correctly, section "K" on page 23 hints that the EHCI
is connected to the internal header only. It should be fully
functional. Unfortunately, Anaconda cannot guess which wires
are connected where.

Comment 10 Gerald Cox 2002-11-06 22:17:01 EST
I don't understand why this was closed as not a bug.  Are you saying the
instructions in the manual are incorrect or that Gigabyte is not provisioning
USB 2.0 to specifications?  Can you please explain?  Thanks!

Note You need to log in before you can comment on or make changes to this bug.