Bug 75601 - .Xdefaults being ignored
.Xdefaults being ignored
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 00:08 EDT by Dmitri A. Sergatskov
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 00:09:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri A. Sergatskov 2002-10-10 00:08:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
.Xdefaults file is being ignored.
Does not matter which session do I start (Failsafe, Gnome, default)
the ~/.Xdefaults file is ignored. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot into 5th runlevel
2.login using any session
3.launch xterm, or any other program that has settings in .Xdefaults
  different from program default. In my case -- xterm (Xterm*font: 10x20,
etc...), gnuplot (gnuplot*geometry: 1024x768) and other.

	

Actual Results:  .Xdefaults is ignored and xterms pops up with wrong fonts,
background, etc...

Expected Results:  .Xdefaults is respected :). xterms starts with 10x20 fonts
black background and wheat foreground as specified in .Xdefaults
(The .Xdefaults can be verified by typing 'xrdb ~.Xdefaults' in any 
 terminal windows and then starting xterm from this window) 

Additional info:

The bug is reproducible on multiple systems, different configs etc...
Comment 1 Mike A. Harris 2002-10-10 07:38:38 EDT
Use .Xresources instead of .Xdefaults.  This is documented in the
XFree86 manpages.  .Xdefaults died a long time ago...
Comment 2 Dmitri A. Sergatskov 2002-10-10 13:51:42 EDT
And which man page would it be? 'man XFree86' has nothing about it.
Neither have RH8.0 release notes.
BTW, this .Xdefaults file used to work for me for almost 10 years 
from Tamu till RedHat7.3 So may be I am just way over the hill and 7 month 
(since rh7.3 release) is indeed a long time ago...

Sincerely,

Dmitri.
Comment 3 Mike A. Harris 2002-10-10 15:37:16 EDT
grep the manpages if you wish.  My point is that this is an XFree86.org
change, and NOT a Red Hat change.  Contact them directly if you
disapprove.
Comment 4 Dmitri A. Sergatskov 2002-10-10 15:47:50 EDT
This point must have been very subtle.

My points are:

You said: "This is documented in XFree86 manpages" and this is not true
(I did grep manpages).

You said: ".Xdefaults died long time ago" and this is not quite true either 
-- XFree86 4.1.x still supported it. 

Sorry, I also did not know that bugzilla is for bugs introduced by Red Hat 
only...
Comment 5 Mike A. Harris 2002-10-10 15:53:24 EDT
My point is that you wont find .Xdefaults documented on the manpages
since it isn't supported.  Red Hat kept the files for a while after
XFree86.org obsoleted them.  Now Red Hat has followed suit also and
gotten rid of them.  There is no need for them, just use Xresources.

This is not a bug introduced by Red Hat, it is an ancient piece
of X legacy from ages ago which was dropped by XFree86 in version
4.0 or thereabouts, and hasn't been supported by XFree86 since then.
Red Hat Linux has added it in as a legacy backwards compat feature
for a while, and it is removed now too.

You can complain all you like, but the Xdefaults is not coming back
period.  End of story.  Now go get a life.


Note You need to log in before you can comment on or make changes to this bug.