Bug 756106 - RHQ Agent resource is UP, but all its child Resources are DOWN
RHQ Agent resource is UP, but all its child Resources are DOWN
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugin Container (Show other bugs)
4.2
Unspecified Unspecified
high Severity high (vote)
: ---
: RHQ 4.3.0,JON 3.0.0
Assigned To: Ian Springer
Mike Foley
:
Depends On:
Blocks: jon30-sprint9
  Show dependency treegraph
 
Reported: 2011-11-22 12:21 EST by Ian Springer
Modified: 2013-08-05 20:42 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:24:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (159.60 KB, image/png)
2011-11-22 12:23 EST, Ian Springer
no flags Details
agent log containing various errors related to null plugin classloader and failing to init plugin classloader (69.68 KB, application/x-zip)
2011-11-22 13:10 EST, Ian Springer
no flags Details

  None (edit)
Description Ian Springer 2011-11-22 12:21:13 EST
This should never happen ...

Each of the DOWN resources has a Resource error like this:

org.rhq.core.clientapi.agent.PluginContainerException: Failed to start component for resource Resource[id=10166, type=Plugin Container, key=rhq.pc:type=PluginContainer, name=Agent Plugin Container, parent=RHQ Agent].
	at org.rhq.core.pc.inventory.InventoryManager.activateResource(InventoryManager.java:1601)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:202)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:238)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.checkInventory(AvailabilityExecutor.java:238)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.call(AvailabilityExecutor.java:127)
	at org.rhq.core.pc.inventory.AvailabilityExecutor.run(AvailabilityExecutor.java:90)
	at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:441)
	at java.util.concurrent.FutureTask$Sync.innerRunAndReset(FutureTask.java:317)
	at java.util.concurrent.FutureTask.runAndReset(FutureTask.java:150)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.access$101(ScheduledThreadPoolExecutor.java:98)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.runPeriodic(ScheduledThreadPoolExecutor.java:180)
	at java.util.concurrent.ScheduledThreadPoolExecutor$ScheduledFutureTask.run(ScheduledThreadPoolExecutor.java:204)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)
	at java.lang.Thread.run(Thread.java:662)
Caused by: java.lang.IllegalStateException: No plugin class loader was specified for org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread@12ec7979.
	at org.rhq.core.pc.inventory.ResourceContainer$ComponentInvocationThread.call(ResourceContainer.java:548)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:303)
	at java.util.concurrent.FutureTask.run(FutureTask.java:138)
	... 3 more


I'm thinking this may be a plugin container bug. Note, I ran the "plugins update" Agent prompt command a couple times prior to noticing this issue.
Comment 1 Ian Springer 2011-11-22 12:23:00 EST
Created attachment 535126 [details]
screenshot
Comment 2 Ian Springer 2011-11-22 13:10:43 EST
Created attachment 535143 [details]
agent log containing various errors related to null plugin classloader and failing to init plugin classloader
Comment 3 Ian Springer 2011-11-22 16:31:37 EST
[master b33a340] - ensure resource classloader is initialized in processSyncInfo() prior to making any resource component facet calls.

QE, try running the "plugins update" Agent prompt command and then checking for Agent child resources being down or any other conspicuous availability-related problems.
Comment 4 Lukas Krejci 2011-11-25 07:15:35 EST
Looks good in master.
Comment 5 Ian Springer 2011-11-28 14:53:23 EST
Cherry-picked to release_jon3.x branch - commit ebdd048:

http://git.fedorahosted.org/git/?p=rhq/rhq.git;a=commitdiff;h=ebdd048
Comment 6 Mike Foley 2012-02-07 14:24:27 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 7 Mike Foley 2012-02-07 14:26:29 EST
marking VERIFIED JON 3 bugs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.