Bug 75616 - Remote connections to MySQL causes mysqld to crash with glibc-2.2.4-30.
Summary: Remote connections to MySQL causes mysqld to crash with glibc-2.2.4-30.
Status: CLOSED DUPLICATE of bug 75128
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 11:17 UTC by Steffen Furholm
Modified: 2016-11-24 15:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 11:17:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Steffen Furholm 2002-10-10 11:17:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)

Description of problem:
Remote connections to MySQL causes mysqld to crash with the following message 
in /var/log/mysqld.log:

Number of processes running now: 1
mysqld process hanging, pid 17993 - killed
021010 12:29:41  mysqld restarted
/usr/libexec/mysqld: ready for connections

When using glibc-2.2.4-30 on a RedHat Linux 7.2 server.


Version-Release number of selected component (if applicable): 2.2.4-30 (i686)


How reproducible:
Always

Steps to Reproduce:
1.Upgrade to glibc-2.2.4-30.
2.Reboot
3.Create a mysql-user with access to a database and enter "%" in host column 
of 'user' and 'db' table.
4.Reload grant tables.
5.Connect with the user from a remove computer.
	

Actual Results:
MySQL crashes with the following output in /var/log/mysqld.log:

Number of processes running now: 1
mysqld process hanging, pid 17993 - killed
021010 12:29:41  mysqld restarted
/usr/libexec/mysqld: ready for connections


Additional info:
Downgrading glibc to glibc-2.2.4-29 (with rpm -Uvh --force glibc*) solves the 
problem.

Comment 1 Jakub Jelinek 2002-10-10 20:24:52 UTC

*** This bug has been marked as a duplicate of 75128 ***


Note You need to log in before you can comment on or make changes to this bug.