Bug 75623 - nautilus unable to access smb: shares
nautilus unable to access smb: shares
Status: CLOSED DUPLICATE of bug 76253
Product: Red Hat Linux
Classification: Retired
Component: gnome-vfs2-extras (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 08:51 EDT by Pavel
Modified: 2015-01-07 19:01 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 15:12:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel 2002-10-10 08:51:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021009

Description of problem:
I'm trying to use nautilus to browse windows shares. When I type 'smb:' in
location bar, nautilus displays list of computers, after double-click on the
computer it asks username/password and displays shares available on the
computer. But after double-clicking the share name nautilus pops up dialog,
saying 'You don't have permissions to see "sharename"'. Security log on the
windows computer shows (successful) logon of the provided user, then logoff of
the user, then (unsuccessful) attempt to log on as GUEST (disabled). It happens
with both NT and Win2k machines. I tried to authenticate as either 'DOMAIN\user'
or as 'user'. Linux box is not member of the domain. Also, I'm able to browse
SMB shares on other linux computers.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Try to browse smb: with nautilus.
	

Actual Results:  Unable to display content of shared folders.

Expected Results:  Display content of the folders

Additional info:
Comment 1 Havoc Pennington 2002-10-10 11:17:39 EDT
Try disabling your firewall, "service ipchains stop"

If that fixes it, you need to use redhat-config-securitylevel or 
manual editing to punch your firewall for smb support.
Comment 2 Pavel 2002-10-10 11:23:54 EDT
I never enabled the firewall (I checked again now - it is disabled). Also, I
have no problems to connect to any computer with smbclient. Other computers can
browse shares on this machine, too.
Comment 3 Thomas Dodd 2002-10-11 15:12:26 EDT
I have the same problems. Several hosts on the network, all using
a Samba machine as PDC and domain logins. The main server and PDC
is running samba-2.2.5 on a Solaris8 machine, I have 2.2.5-10 from
psyche on a PC. There are severl Windoze machines, Win95, 98, and
XP all on the network. All windows machines can browse all shares
fine. nautilus cannot show the shares on any machine with smb:
protocol. It does show domains, and machines in the domains correctly,
but all machines have no shares.

The Red Hat build of samba doesn't leave anyinfo in the logs, but the
Solaris machine does. When trying to access a share on it, I see this
in the per-machine log:

[2002/10/11 14:04:10, 0] smbd/password.c:domain_client_validate(1549)
  domain_client_validate: could not fetch trust account password for domain CSDC
[2002/10/11 14:04:21, 0] smbd/password.c:domain_client_validate(1549)
  domain_client_validate: could not fetch trust account password for domain CSDC

These occur for smb:/// and smb://csdc (the workgroup/domain name)
I get nothing when accessing the machine. I also tried the method from the
vfs2-extras docs, smb://user:pass@server/share and no go (no log message
either). I also tries @WG/server/share and @WG/server with the same results.

Comment 4 Alexander Larsson 2002-11-06 03:19:49 EST

*** This bug has been marked as a duplicate of 76253 ***

Note You need to log in before you can comment on or make changes to this bug.