Bug 756239 - leading space missing when copying text from Zanata source column in Firefox 3
leading space missing when copying text from Zanata source column in Firefox 3
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Sean Flanigan
David Mason
:
Depends On:
Blocks: zanata-1.5.0
  Show dependency treegraph
 
Reported: 2011-11-22 20:30 EST by Mie Yamamoto
Modified: 2012-03-06 19:07 EST (History)
3 users (show)

See Also:
Fixed In Version: 1.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-06 19:07:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mie Yamamoto 2011-11-22 20:30:30 EST
Description of problem:
When copying original text to the target, space in front of the string isnt included in the translation space.

e.g.
Copy this string " <literal>Red Had Enterprise Virtulization Manager</literal> " with the space in front and at the end, and paste it in the translated string.
the space in front will disappear. 


Version-Release number of selected component (if applicable):


How reproducible:
everytime

Steps to Reproduce:
1. copy a word with a space infront
2. paste it in the target 
3. 
  
Actual results:
the space in front isnt copied. 

Expected results:
space should be included.

Additional info:
Comment 2 Sean Flanigan 2012-02-13 22:37:54 EST
This doesn't happen in Chrome 17, but it does happen in Firefox 3.6.26.  It seems to be a browser limitation, because Firefox often fails to copy leading spaces in a variety of web pages, not just Zanata.

This discussion seems to be related: https://groups.google.com/d/topic/codemirror/eIOIOlVhv4s/discussion

I'll see if upgrading codemirror helps.
Comment 3 Sean Flanigan 2012-02-15 00:23:56 EST
This is caused by a Firefox bug: https://bugzilla.mozilla.org/show_bug.cgi?id=116083

Upgrading CodeMirror didn't help by itself, but I've changed the text cells to use "pre" elements as a workaround.

Fixed in https://github.com/zanata/zanata/commit/27996321de64ed9b6e48dc6781df25183131ddc2 (master).
Comment 4 David Mason 2012-02-19 19:59:29 EST
Reviewed code and verified in Firefox 3.6.18

Note You need to log in before you can comment on or make changes to this bug.