Bug 75626 - Cannot print some fonts
Summary: Cannot print some fonts
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-print   
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Owen Taylor
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 13:05 UTC by Ottavio G. Rizzo
Modified: 2007-04-18 16:47 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 21:43:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
It shows the reported behaviour (1.77 KB, application/x-gnumeric)
2002-10-10 13:08 UTC, Ottavio G. Rizzo
no flags Details

Description Ottavio G. Rizzo 2002-10-10 13:05:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.1) Gecko/20020827

Description of problem:
If I use, say Verdana, for a cell, it would not show even in print preview. If I
use regular Helvetica or Nimbus Sans, it will show correctly in print preview,
in ggv, but the postscript printer will subsitute the font with Courier. This
does not happen if I use bold or italic.

If I correct the postscript file with ps2ps, then it will work; so I assume it
is not a problem with the printer. Besides, the same file worked file before I
upgraded to 8.0

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Open the attached file
2.Go to +Print Preview;
3.Print on a postscript printer 
	

Actual Results:  After step 2, the cells in Verdana disappear
After step 3, the cells in Helvetica and Nimbus Sans (both regular) are
substituted with Courier

Expected Results:  Every cell should have been printed as it appears on screen

Additional info:

Loadin the file, I get a lot of error message of the type:
** CRITICAL **: file gnome-font-face.c: line 613 (gff_load): assertion
`ft_result == FT_Err_Ok' failed.

** WARNING **: file gnome-font-face.c: line 308: Face Verdana-Bold: Cannot load
face

Comment 1 Ottavio G. Rizzo 2002-10-10 13:08:27 UTC
Created attachment 79764 [details]
It shows the reported behaviour

Comment 2 Miloslav Trmac 2002-10-10 17:43:54 UTC
If you use postscript printers and fonts outside the standard postscript set,
using 'prerender postscript' in printconf is probably a good idea, exactly
because it embeds the fonts in the postscript files.

Comment 3 Owen Taylor 2003-08-28 21:43:29 UTC
gnumeric has been upgraded to a gnome-2 based version in Raw Hide, which
uses a newer version of gnome-print. Trying to fix the old gnome-1 
version of gnome-print isn't something that's very worthwhile at this
point.



Note You need to log in before you can comment on or make changes to this bug.