Bug 756278 - [abrt] gnome-online-accounts-3.2.1-2.fc16: __GI_raise: Process /usr/libexec/goa-daemon was killed by signal 6 (SIGABRT)
[abrt] gnome-online-accounts-3.2.1-2.fc16: __GI_raise: Process /usr/libexec/g...
Status: CLOSED DUPLICATE of bug 737640
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:8ede871c1664491754f84d3be2c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 00:21 EST by Pete Travis
Modified: 2012-09-07 12:41 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-07 12:41:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (7.39 KB, text/plain)
2011-11-23 00:21 EST, Pete Travis
no flags Details
File: build_ids (3.36 KB, text/plain)
2011-11-23 00:21 EST, Pete Travis
no flags Details
File: maps (33.46 KB, text/plain)
2011-11-23 00:21 EST, Pete Travis
no flags Details
File: backtrace (32.23 KB, text/plain)
2011-11-23 00:21 EST, Pete Travis
no flags Details
File: backtrace (42.09 KB, text/plain)
2012-02-09 12:26 EST, Russell Harrison
no flags Details
File: backtrace (39.36 KB, text/plain)
2012-02-21 21:38 EST, Jose Francisco Beltran Neira
no flags Details
File: backtrace (41.37 KB, text/plain)
2012-03-07 12:13 EST, Kayvan Sylvan
no flags Details
File: backtrace (47.46 KB, text/plain)
2012-04-28 10:31 EDT, Robert Keersse
no flags Details

  None (edit)
Description Pete Travis 2011-11-23 00:21:42 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/libexec/goa-daemon
crash_function: __GI_raise
executable:     /usr/libexec/goa-daemon
kernel:         3.1.1-2.fc16.x86_64
pid:            12639
pwd:            /
reason:         Process /usr/libexec/goa-daemon was killed by signal 6 (SIGABRT)
time:           Tue 22 Nov 2011 09:12:16 PM MST
uid:            1000
username:       pete

backtrace:      Text file, 33000 bytes
build_ids:      Text file, 3444 bytes
dso_list:       Text file, 7572 bytes
maps:           Text file, 34263 bytes

comment:
:              I set up online accounts using gnome, then installed KDE and launched evolution. It looks like initially, KDE wasn't able to access my gnome keyring - there was a popup from either KDE or evolution asking for authentication to the keyring - but gnome-keyring and gnome-online-accounts were reported as crashed.  Evolution did not wait for the keyring, but continued to load without authentication and was unable to access the accounts.  This is probably a minor issue, and I don't know enough about how these things together to make a more concrete assessment.  After working through the keyring authentication dialog and relaunching Evolution, all appears to be functioning as expected.  
:
:I'm filing this against gnome-keyring and gnome-online-accounts for due dilligence.

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-Oi7C0OHt13,guid=67206b2732058accf2b6c8ea00000bed
:XDG_SESSION_COOKIE=ef3792fb0a4a2e8aff019ad30000000b-1322019549.405172-571409777
:XDG_RUNTIME_DIR=/run/user/pete
:DISPLAY=:0
:DESKTOP_SESSION=kde-plasma
:WINDOWPATH=2
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=kde-plasma
:XDG_VTNR=2
:USERNAME=pete
:XDG_SESSION_ID=13
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Oi7C0OHt13,guid=67206b2732058accf2b6c8ea00000bed
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-pete-cx9e3w/database
:USER=pete
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=12061
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/pete
:GNOME_KEYRING_CONTROL=/tmp/keyring-eHfmDw
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=pete
:HOME=/home/pete

var_log_messages:
:Nov 22 08:04:02 thefool goa[2178]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 16:52:53 thefool goa[4442]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 16:58:50 thefool goa[5413]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 17:01:58 thefool goa[6087]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 17:03:06 thefool goa[6592]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 17:04:27 thefool goa[7098]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 17:21:35 thefool goa[10175]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 17:29:39 thefool goa[10960]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 21:12:13 thefool goa[12639]: goa-daemon version 3.2.1 starting [main.c:112, main()]
:Nov 22 21:12:16 thefool abrt[12655]: Saved core dump of pid 12639 (/usr/libexec/goa-daemon) to /var/spool/abrt/ccpp-2011-11-22-21:12:16-12639 (38154240 bytes)
:Nov 22 21:12:16 thefool goa[12668]: goa-daemon version 3.2.1 starting [main.c:112, main()]
Comment 1 Pete Travis 2011-11-23 00:21:47 EST
Created attachment 535342 [details]
File: dso_list
Comment 2 Pete Travis 2011-11-23 00:21:48 EST
Created attachment 535343 [details]
File: build_ids
Comment 3 Pete Travis 2011-11-23 00:21:50 EST
Created attachment 535344 [details]
File: maps
Comment 4 Pete Travis 2011-11-23 00:21:52 EST
Created attachment 535345 [details]
File: backtrace
Comment 5 Russell Harrison 2012-02-09 12:26:13 EST
Recieved error opening evolution that it could not contact the dbus service

backtrace_rating: 4
Package: gnome-online-accounts-3.2.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 6 Russell Harrison 2012-02-09 12:26:16 EST
Created attachment 560669 [details]
File: backtrace
Comment 7 Jose Francisco Beltran Neira 2012-02-21 21:38:37 EST
startup the system 

backtrace_rating: 4
Package: gnome-online-accounts-3.2.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 8 Jose Francisco Beltran Neira 2012-02-21 21:38:42 EST
Created attachment 564817 [details]
File: backtrace
Comment 9 Kayvan Sylvan 2012-03-07 12:13:20 EST
Logging in.

backtrace_rating: 4
Package: gnome-online-accounts-3.2.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 10 Kayvan Sylvan 2012-03-07 12:13:24 EST
Created attachment 568366 [details]
File: backtrace
Comment 11 Robert Keersse 2012-04-28 10:31:11 EDT
send/receive use F9

backtrace_rating: 4
Package: gnome-online-accounts-3.2.1-2.fc16
OS Release: Fedora release 16 (Verne)
Comment 12 Robert Keersse 2012-04-28 10:31:28 EDT
Created attachment 580974 [details]
File: backtrace
Comment 13 Daniel Rindt 2012-08-24 09:45:16 EDT
Just switches back to online mode in eclipse

backtrace_rating: 4
Package: gnome-online-accounts-3.4.2-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 Debarshi Ray 2012-09-07 12:41:39 EDT

*** This bug has been marked as a duplicate of bug 737640 ***

Note You need to log in before you can comment on or make changes to this bug.