Bug 756293 - Not able to work parallel on the same workbench
Summary: Not able to work parallel on the same workbench
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Zanata
Classification: Retired
Component: Usability   
(Show other bugs)
Version: 1.4.2
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ---
: ---
Assignee: Alex Eng
QA Contact: Ding-Yi Chen
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: Zanata-1.4.3
TreeView+ depends on / blocked
 
Reported: 2011-11-23 06:37 UTC by Chester Cheng
Modified: 2016-06-23 04:45 UTC (History)
3 users (show)

Fixed In Version: 1.4.3-alpha-3-SNAPSHOT (20111128-1320)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-23 04:32:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chester Cheng 2011-11-23 06:37:41 UTC
Description of problem:
Not able to work parallel on the same workbench

Version-Release number of selected component (if applicable):
Zanata version 1.4.2 (20111031-0915)

How reproducible:
Every time

Steps to Reproduce:
1.  Two people log in and work on https://translate.zanata.org/zanata/webtrans/Application.html?project=pulp&iteration=0.1&localeId=zh-Hant-TW&locale=en .   Not necessary to be working in the same page or same string
2.  Both start typing and save.
3.  One's saving makes the other lose what he's typing, and leave his input box.
  
Actual results:
As 3.

Expected results:
To be able to work parallel.

Additional info:

Comment 2 Sean Flanigan 2011-11-23 23:42:18 UTC
Correction: This must have broken between 1.4.1 and 1.4.2, or I think we would have heard about it before now.

Comment 3 Alex Eng 2011-11-24 01:27:15 UTC
Unable to reproduce problem: 
1. 2 users login into http://zanata-fortitude.lab.eng.bne.redhat.com:8080/ as   different user.
2. Navigate into IBUS-chewing project, into first document
3. User1 edit entry 1 and user2 edit entry 2.
4. User1 hit save, user2 still remain in editor with no content lost.

Can you please confirm if this is the correct way to reproduce the bug?

Comment 7 Ding-Yi Chen 2011-11-29 03:50:37 UTC
VERIFIED with Zanata version 1.4.3-alpha-3-SNAPSHOT (20111128-1320)


Note You need to log in before you can comment on or make changes to this bug.