Bug 756317 - grubby handles multiple superusers incorrectly, makes grub2 unlockable
grubby handles multiple superusers incorrectly, makes grub2 unlockable
Status: CLOSED DUPLICATE of bug 742720
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 03:56 EST by Sandro Mathys
Modified: 2011-11-25 11:03 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-25 11:03:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sandro Mathys 2011-11-23 03:56:52 EST
Description of problem:
If there's multiple superusers defined in grub2.cfg and grubby is run (like when a new kernel is installed), the various superusers are broken, i.e. the space between the users is removed.

Version-Release number of selected component (if applicable):
grubby-8.3-1.fc16.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. put set superusers="foo bar" into /etc/grub2/grub.cfg
2. do the grubby
3. find set superusers="foobar" in /etc/grub2/grub.cfg
  
Actual results:
Can't unlock grub2 with any superuser anymore.

Expected results:
Can unlock grub2 with any superuser.

Additional info:
Comment 1 Mads Kiilerich 2011-11-25 11:03:03 EST

*** This bug has been marked as a duplicate of bug 742720 ***

Note You need to log in before you can comment on or make changes to this bug.