Bug 75637 - KDE taskbar too small
KDE taskbar too small
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
: 86309 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 11:08 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-09-06 22:20:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Here's an example. No matter how many tasks you start, they are only allowed to occupy the same space as if there was just 1 task. (65.17 KB, image/png)
2002-11-26 07:06 EST, Need Real Name
no flags Details

  None (edit)
Description Carlos Rodrigues 2002-10-10 11:08:34 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
If I have few icons on kicker's left side and put the taskbar next to it , the
taskbar does not occupy all the free space until the next item on the right
side. However, if I leave some blank space between the icons and the taskbar
(taskbar's left side almost at the middle of kicker) it occupies all the free space.

How reproducible:
Always

Steps to Reproduce:
1.Put the taskbar close to the icons on the left side of kicker.
2.Look at the size of the taskbar
3.Move it right until the size changes occupying all the remaining space.

Actual Results:  After 1. the taskbar is small and doesn't even grow when the
number of buttons in it increases.
After some iterations of 3. the taskbar assumes the desired behaviour.

Expected Results:  It should always occupy all the free space.
Comment 1 Tan Zheng Da 2002-10-13 11:59:25 EDT
I confirm the same behavior.  This is very irritating.  Please get it fixed!

-- 
tzd.
Comment 2 Ngo Than 2002-10-16 10:01:59 EDT
Hmm, i don't think it's a bug. It's correct that the taskbar occupies a default
size and it retains this size unless someone want to resize it.
Comment 3 Carlos Rodrigues 2002-10-16 15:26:58 EDT
It never exibited this behaviour in 7.3, 7.2 or whatever. I even installed KDE
3.0.3 from sources on 7.3 and it worked as expected. If the taskbar has a
default size I should be able to define it somewhere. Besides that, the size of
the taskbar varies depending on the place it is on the same free space area
within kicker.
When I have a block of free space on kicker, if the taskbar was supposed to have
a fixed size it should retain that size if it was on the left side of the free
space, the center or the right side. Since the size changes for no apparent
reason it is indeed a bug.

Additionaly I noticed that, when performing the steps mentioned in the original
bug report until the taskbar reaches the position where it occupies all the free
space until the next element on the right side it doesn't move smoothly, it
moves like there were some invisible elements there (like when moving the
taskbar to the middle of the existing launcher icons).

But there is more, it is unnatural for the taskbar not to grow horizontally when
there are more open app buttons, the more buttons the smaller they get until the
taskbar is completely unusable (it only needs a half a dozen windows open to
reach this point).

Therefore and with all due respect, it is a bug and it should be reopened.
Comment 4 Carlos Rodrigues 2002-10-16 15:31:25 EDT
Actually the KDE 3.0.3 packages that I used on 7.3 were in fact the binary rpms
from ftp.kde.org not actually compiled from the source code by myself. Sorry for
the inaccuracy.
Comment 5 Carlos Rodrigues 2002-10-16 17:16:49 EDT
I believe that this might be related with bug #76103. It might not be a taskbar
itself bug but a kicker one. Of course this is just IMHO.
Comment 6 Need Real Name 2002-11-26 07:06:40 EST
Created attachment 86504 [details]
Here's an example. No matter how many tasks you start, they are only allowed to occupy the same space as if there was just 1 task.
Comment 7 Ngo Than 2002-11-26 08:36:35 EST
it's very strange, how this bug has appeared on your machine.

I really cannot reproduce this bug on many machines with 8.0.
It works for me.

Maybe some old KDE configurations in your home could cause such problem.

Could you please try to add a fesh new user and start KDE with this user and
look if it still appears.

Than
Comment 8 Carlos Rodrigues 2002-11-26 17:37:31 EST
I just created a fresh user, ran "switchdesk KDE" and then "startx".

The first run I moved the taskbar applet a bit to the left (it jumped as if it
was moving through some invisible icons, which I think is the problem - or the
main symptom) and then released it. The taskbar does not occupy all the space up
to the next applet on the right side anymore as it should.
Comment 9 Ngo Than 2002-12-19 15:15:11 EST
Hmm, tried with new user again and still cannot reproduce it!

could you please try KDE 3.0.5 from
ftp://ftp.kde.org/pub/kde/stable/3.0.5/RedHat/8.0/i386/

Does it work for you?
Comment 10 Carlos Rodrigues 2002-12-30 13:08:46 EST
I've just tried kde 3.0.5a from ftp.kde.org (the rpms for Red Hat 8.0) and the
bug is still here. I've also created a new user just to test it cleanly, the bug
is also there.
Comment 11 Ngo Than 2003-01-03 05:55:04 EST
Hmm, i have installed 7.2 and 7.3 and 8.0 on my local machine at weekend to
reproduce this problem. It works fine for me with 7.2/7.3 and 8.0.

sorry, i close it as not a bug.
Comment 12 Jason Filsinger 2003-01-07 10:17:27 EST
I have been having the same problem ever sense I installed 8.0.  This problem 
seems to be caused by a ghost button,  a button that does not exist, but the 
kicker thinks it exists. 
  
Take a look at ~/.kde/share/congif/kickerrc  
  
look for the line under the [General] section with the Applets= on it.  
The problem for me was that ServiceButton_2 was on this line, but the  
ServiceButton_2 was not defined anywhere in this config file.  I just removed  
the ServiceButton_2 from the line and it fixed this bug and the bug reported  
in #76103.  
  
If somebody could check there ~/.kde/share/config/kickerrc and see if the  
problem is similar or even better if it is the exact same as mine then this is  
probably the solution.   
Comment 13 Jason Filsinger 2003-01-07 10:25:17 EST
Sorry, my mind got ahead of my fingers. the dir the kickerrc is in is    
~/.kde/share/config,  not ~/.kde/share/congif 
Comment 14 Carlos Rodrigues 2003-01-09 17:55:06 EST
Removing the entries for the ghost buttons on kickerrc fixed it for me too.
Comment 15 Ngo Than 2003-02-15 17:11:01 EST
i close it as NOTABUG.
Comment 16 Alexey Neyman 2003-03-19 09:20:33 EST
Please reopen it. Though a workaround is suggested; it's not a real 
fix: 
 
* Missing definition for ServiceButton_X is not invalid; it just 
refers to system-wide settings for kicker in the /usr/share/config/kickerrc 
file. As for me, ServiceButton_1 (which is not defined in the 
~/.kde/share/config/kickerrc) refers to Mozilla browser (which has the 
same number in the system-wide kickerrc file) 
* In any case, it's kicker, not user who writes such values in its config. 
Does user have to learn the structure of each and every KDE config file and 
edit them manually? 
 
By the way, due to this bug being closed I accidentally submitted its 
duplicate, bug 86309 (and I did not include 'closed' bugs when I searched). 
Please mark that as duplicate and reopen this. 
Comment 17 Alexey Neyman 2003-03-19 09:22:13 EST
*** Bug 86309 has been marked as a duplicate of this bug. ***
Comment 18 Carlos Rodrigues 2003-03-19 18:10:11 EST
Well I agree that the existance of incorrect entries in the config file is a bug.
Comment 19 Carlos Rodrigues 2003-09-06 22:20:58 EDT
No problem in Red Hat 9

Note You need to log in before you can comment on or make changes to this bug.