Bug 75642 - man pages not displaying correctly in xterm
man pages not displaying correctly in xterm
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: wdovlrrw
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 11:53 EDT by Samuel Flory
Modified: 2007-04-18 12:47 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-24 14:01:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samuel Flory 2002-10-10 11:53:33 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
Man is not correct displaying man pages under xterm.  

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.start xterm
2.man ls
3.Note the lack of - signs
	

Additional info:
Comment 1 Need Real Name 2002-10-10 13:58:59 EDT
This is not only an xterm problem, but also at the console and evident as well 
when ssh'ing into RH8.0 boxes.  

You can fix the xterm problem by changing terminal fonts.  I have not been able 
to find a work around at the console.
Comment 2 Neil Prockter 2002-10-10 17:14:12 EDT
the answer lies in the release notes-

env LANG=C man bash

perhaps-
alias man="env LANG=C man"
Comment 3 Need Real Name 2002-10-10 18:54:02 EDT
There are other apps that this causes a problem in for which env LANG=C does 
not work. 
 
For instance, ntsysv and netconfig do not display correctly either. 
 
Regards, 
Patrick
Comment 4 Samuel Flory 2002-10-11 13:25:44 EDT
alias man="env LANG=C man"  does seem to fix man under xterm.  It also appears
to fix related issues in ntsysv and the like.  It really should be fixed
invisibly to a user.
Comment 5 Need Real Name 2002-10-11 13:58:12 EDT
Worked only partially for me.  In an ssh window using Putty, all looks good 
using env LANG=C, but on a terminal from inside KDE, ntsysv, etc. are still not 
looking correct.  I can correct the problem by changing the default font to 
something else.  Gnome seems to be working fine.
Comment 6 Need Real Name 2002-10-11 14:52:39 EDT
Answer is here:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=75089
Comment 7 phostetl 2002-10-24 14:01:22 EDT
*** Bug 76181 has been marked as a duplicate of this bug. ***
Comment 8 phostetl 2002-10-24 14:01:28 EDT
gnome-terminal has this problem too:

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=76181
Comment 9 Mike A. Harris 2002-10-24 21:14:18 EDT
This isn't a bug.  You're displaying manpages on a system using one
encoding, while the system you're viewing them on is using a different
encoding.

Solution:  Configure both of the systems to use the exact same 8bit
encoding.  This isn't something that can be autodetect or otherwise
"just work".  It is something that requires a user to configure all
of their systems to use the same encoding in order to ensure applications
are speaking the same language.
Comment 10 R P Herrold 2002-10-28 15:50:02 EST
Mike -- I checked Paul's system -- this is same system to same system -- all
within the stoch RHL 8.0, default Gnome absed desktop ... and a clean kitched
sinkish install ...

Probably implies integration issues with the release on LANG issues.
Comment 11 Derek Martin 2002-12-18 02:09:21 EST
See my comments at the end of bug #75089 for several solutions to this problem.

Note You need to log in before you can comment on or make changes to this bug.