Bug 756495 - Tray icon extension doesn't work
Summary: Tray icon extension doesn't work
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: parole
Version: 16
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-23 19:11 UTC by Heiko Adams
Modified: 2012-11-25 23:57 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-25 23:57:12 UTC


Attachments (Terms of Use)

Description Heiko Adams 2011-11-23 19:11:21 UTC
Description of problem:
When launching parole normal it's impossible to activate the tray-icon extension. It gets disabled after closing the extensions window. When launching parole from shell the following error message is shown

> (parole:5186): parole-CRITICAL **: Failed to load plugin : /usr/lib/parole-0/tray-icon.so: undefined symbol: notify_notification_attach_to_status_icon

Version-Release number of selected component (if applicable):
parole-0.2.0.2-6.fc15.i686

How reproducible:
allways

Steps to Reproduce:
1. open parole
2. open the extensions window and activate the tray-icon extension
3. close and reopen the extensions window
  
Actual results:
the tray-icon extension is disabled

Expected results:
the tray-icon extension should be activated and work as expected

Additional info:

Comment 1 Christoph Wickert 2011-11-23 20:07:01 UTC
(In reply to comment #0)
> When launching parole normal it's impossible to activate the tray-icon
> extension.

Confirmed.
> > (parole:5186): parole-CRITICAL **: Failed to load plugin : /usr/lib/parole-0/tray-icon.so: undefined symbol: notify_notification_attach_to_status_icon

notify_notification_attach_to_status_icon is no longer supported in libnotify 0.7.

Seems I made a mistake when I updated to 2.0.6 in F16 back in June. I removed the libnotify patch because 2.0.6 contains already contains it, but still built the old 2.0.2 package.

2.0.6 unfortunately no longer contains the mozilla plugin, so I cannot just update in F16. This needs to be discussed on the mailing list first I think.

Comment 2 Heiko Adams 2012-05-02 20:51:19 UTC
FYI parole 0.2.0.6 from the xfce-4.10 repo has a working tray icon extension

Comment 3 Christoph Wickert 2012-10-06 23:49:37 UTC
Blocking F18Xfce so I don't forget to look into this.

Comment 4 Tim Lauridsen 2012-10-18 05:12:13 UTC
Look like this is working now.

pragha-1.1.1-1.fc18.x86_64 (F18 Xfce installed from Xfce Spin Beta TC4)

Comment 5 Christoph Wickert 2012-10-18 11:15:01 UTC
This bug is about parole, not about pragha. But it's fixed, parole 0.3.x is not affected.

I still want to verify 0.2.x on F16 before I close this, so right now I'll only remove the dependency to the F18Xfce tracking bug.

Comment 6 Tim Lauridsen 2012-10-19 13:37:42 UTC
Damn, I always mix up these two :)

parole-0.3.0.3-1.fc18.i686 is working for me in at F18 Beta TC4 installation with current updates.

Comment 7 Christoph Wickert 2012-10-19 13:43:08 UTC
Yes, only 0.2.x is affected. I already found the problem and know how to fix it, I just didn't have the time.

Comment 8 Fedora Update System 2012-10-20 10:34:04 UTC
parole-0.2.0.2-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/parole-0.2.0.2-7.fc17

Comment 9 Fedora Update System 2012-10-20 10:34:23 UTC
parole-0.2.0.2-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/parole-0.2.0.2-7.fc16

Comment 10 Fedora Update System 2012-10-22 01:56:41 UTC
Package parole-0.2.0.2-7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parole-0.2.0.2-7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16586/parole-0.2.0.2-7.fc16
then log in and leave karma (feedback).

Comment 11 Christoph Wickert 2012-11-25 23:57:12 UTC
This was pushed to stable weeks ago, but bodhi forgot to notify bugzilla. Closing.


Note You need to log in before you can comment on or make changes to this bug.