Bug 756513 - php-phpunit-File-Iterator 1.3 is not compatible with php-phpunit-PHPUnit 3.5
php-phpunit-File-Iterator 1.3 is not compatible with php-phpunit-PHPUnit 3.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: php-phpunit-File-Iterator (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christof Damian
Fedora Extras Quality Assurance
:
: 758832 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-23 15:02 EST by Jon Dufresne
Modified: 2012-02-04 18:50 EST (History)
5 users (show)

See Also:
Fixed In Version: php-phpunit-PHPUnit-MockObject-1.1.1-1.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-04 18:50:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jon Dufresne 2011-11-23 15:02:51 EST
Description of problem:
phpunit no longer works because of incompatible library version php-phpunit-File-Iterator

Either phpunit should be upgraded or file iterator downgraded. See here:

https://github.com/sebastianbergmann/php-file-iterator/issues/9

$ rpm -qa php-phpunit*
php-phpunit-PHPUnit-3.5.15-1.fc15.noarch
php-phpunit-DbUnit-1.0.3-1.fc15.noarch
php-phpunit-File-Iterator-1.3.0-1.fc15.noarch
php-phpunit-phploc-1.6.1-1.fc15.noarch
php-phpunit-Text-Template-1.1.0-2.fc15.noarch
php-phpunit-PHP-CodeBrowser-1.0.1-1.fc15.noarch
php-phpunit-PHPUnit-MockObject-1.0.9-1.fc15.noarch
php-phpunit-PHP-Invoker-1.0.0-3.fc15.noarch
php-phpunit-PHP-Timer-1.0.2-2.fc15.noarch
php-phpunit-phpdcd-0.9.2-2.fc15.noarch
php-phpunit-bytekit-1.1.2-3.fc15.noarch
php-phpunit-phpcpd-1.3.3-3.fc15.noarch
php-phpunit-PHPUnit-Selenium-1.0.3-1.fc15.noarch
php-phpunit-PHP-TokenStream-1.1.0-2.fc15.noarch
php-phpunit-PHP-CodeCoverage-1.0.5-1.fc15.noarch
Comment 1 Jon Dufresne 2011-11-24 11:58:51 EST
Output from the latest version demonstrating the error'


$ phpunit
PHP Fatal error:  Class 'File_Iterator' not found in /usr/share/pear/File/Iterator/Factory.php on line 105
PHP Stack trace:
PHP   1. {main}() /usr/bin/phpunit:0
PHP   2. require_once() /usr/bin/phpunit:45
PHP   3. PHP_CodeCoverage_Filter->addDirectoryToBlacklist() /usr/share/pear/PHPUnit/Autoload.php:68
PHP   4. File_Iterator_Factory->getFileIterator() /usr/share/pear/PHP/CodeCoverage/Filter.php:113

Fatal error: Class 'File_Iterator' not found in /usr/share/pear/File/Iterator/Factory.php on line 105

Call Stack:
    0.0002     631800   1. {main}() /usr/bin/phpunit:0
    0.0009     749160   2. require_once('/usr/share/pear/PHPUnit/Autoload.php') /usr/bin/phpunit:45
    0.0011     775880   3. PHP_CodeCoverage_Filter->addDirectoryToBlacklist() /usr/share/pear/PHPUnit/Autoload.php:68
    0.0011     775880   4. File_Iterator_Factory->getFileIterator() /usr/share/pear/PHP/CodeCoverage/Filter.php:113
Comment 2 Remi Collet 2011-12-01 00:47:16 EST
*** Bug 758832 has been marked as a duplicate of this bug. ***
Comment 3 Remi Collet 2011-12-01 00:54:56 EST
Because of new autoload feature in phpunit stack, this break API.

That's the reason why I have only plan to update PHPUnit 3.6 only in F16.

We need to fix this issue, in f15 and f16.

@Christof, I see 2 solutions
- downgrade File_Iterator
- upgrade PHPUnit stack (about 8 packages)

The second is probably the simplest, despite the API break.
Comment 4 Remi Collet 2011-12-01 00:55:25 EST
=> f15 and el6 (f16 is ok)
Comment 5 Christof Damian 2011-12-01 01:07:04 EST
(In reply to comment #3)
> Because of new autoload feature in phpunit stack, this break API.
> 
> That's the reason why I have only plan to update PHPUnit 3.6 only in F16.
> 
> We need to fix this issue, in f15 and f16.
> 
> @Christof, I see 2 solutions
> - downgrade File_Iterator
> - upgrade PHPUnit stack (about 8 packages)
> 
> The second is probably the simplest, despite the API break.

It is annoying that sebastian broke backward compatibility as other tools are using this too.

I am away until the 12th, if there is any way for you to fix this before it would be appreciated.
Comment 6 Fedora Update System 2012-01-17 13:36:23 EST
php-phpunit-DbUnit-1.1.1-1.fc15,php-phpunit-File-Iterator-1.3.1-1.fc15,php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15,php-phpunit-PHP-Invoker-1.0.1-1.fc15,php-phpunit-PHP-TokenStream-1.1.2-1.fc15,php-phpunit-PHPUnit-3.6.7-1.fc15,php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15,php-phpunit-PHPUnit-MockObject-1.1.0-1.fc15,php-phpunit-Text-Template-1.1.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/php-phpunit-DbUnit-1.1.1-1.fc15,php-phpunit-File-Iterator-1.3.1-1.fc15,php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15,php-phpunit-PHP-Invoker-1.0.1-1.fc15,php-phpunit-PHP-TokenStream-1.1.2-1.fc15,php-phpunit-PHPUnit-3.6.7-1.fc15,php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15,php-phpunit-PHPUnit-MockObject-1.1.0-1.fc15,php-phpunit-Text-Template-1.1.1-1.fc15
Comment 7 Fedora Update System 2012-01-18 20:40:35 EST
Package php-phpunit-DbUnit-1.1.1-1.fc15, php-phpunit-File-Iterator-1.3.1-1.fc15, php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15, php-phpunit-PHP-Invoker-1.0.1-1.fc15, php-phpunit-PHP-TokenStream-1.1.2-1.fc15, php-phpunit-PHPUnit-3.6.7-1.fc15, php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15, php-phpunit-PHPUnit-MockObject-1.1.0-1.fc15, php-phpunit-Text-Template-1.1.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-phpunit-DbUnit-1.1.1-1.fc15 php-phpunit-File-Iterator-1.3.1-1.fc15 php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15 php-phpunit-PHP-Invoker-1.0.1-1.fc15 php-phpunit-PHP-TokenStream-1.1.2-1.fc15 php-phpunit-PHPUnit-3.6.7-1.fc15 php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15 php-phpunit-PHPUnit-MockObject-1.1.0-1.fc15 php-phpunit-Text-Template-1.1.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0687/php-phpunit-DbUnit-1.1.1-1.fc15,php-phpunit-File-Iterator-1.3.1-1.fc15,php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15,php-phpunit-PHP-Invoker-1.0.1-1.fc15,php-phpunit-PHP-TokenStream-1.1.2-1.fc15,php-phpunit-PHPUnit-3.6.7-1.fc15,php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15,php-phpunit-PHPUnit-MockObject-1.1.0-1.fc15,php-phpunit-Text-Template-1.1.1-1.fc15
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-01-19 17:00:33 EST
Package php-phpunit-PHPUnit-MockObject-1.1.1-1.fc15, php-phpunit-DbUnit-1.1.1-1.fc15, php-phpunit-File-Iterator-1.3.1-1.fc15, php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15, php-phpunit-PHP-Invoker-1.0.1-1.fc15, php-phpunit-PHP-TokenStream-1.1.2-1.fc15, php-phpunit-PHPUnit-3.6.7-1.fc15, php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15, php-phpunit-Text-Template-1.1.1-1.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing php-phpunit-PHPUnit-MockObject-1.1.1-1.fc15 php-phpunit-DbUnit-1.1.1-1.fc15 php-phpunit-File-Iterator-1.3.1-1.fc15 php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15 php-phpunit-PHP-Invoker-1.0.1-1.fc15 php-phpunit-PHP-TokenStream-1.1.2-1.fc15 php-phpunit-PHPUnit-3.6.7-1.fc15 php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15 php-phpunit-Text-Template-1.1.1-1.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0687/php-phpunit-DbUnit-1.1.1-1.fc15,php-phpunit-File-Iterator-1.3.1-1.fc15,php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15,php-phpunit-PHP-Invoker-1.0.1-1.fc15,php-phpunit-PHP-TokenStream-1.1.2-1.fc15,php-phpunit-PHPUnit-3.6.7-1.fc15,php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15,php-phpunit-PHPUnit-MockObject-1.1.1-1.fc15,php-phpunit-Text-Template-1.1.1-1.fc15
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-02-04 18:50:14 EST
php-phpunit-PHPUnit-MockObject-1.1.1-1.fc15, php-phpunit-DbUnit-1.1.1-1.fc15, php-phpunit-File-Iterator-1.3.1-1.fc15, php-phpunit-PHP-CodeCoverage-1.1.1-1.fc15, php-phpunit-PHP-Invoker-1.0.1-1.fc15, php-phpunit-PHP-TokenStream-1.1.2-1.fc15, php-phpunit-PHPUnit-3.6.7-1.fc15, php-phpunit-PHPUnit-Selenium-1.2.0-1.fc15, php-phpunit-Text-Template-1.1.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.