Bug 75652 - parse error before "attribute_hidden" in libio.h
parse error before "attribute_hidden" in libio.h
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kdesdk (Show other bugs)
8.0
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 14:12 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-10 14:17:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-10 14:12:18 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; pt-BR; rv:1.1) Gecko/20020827

Description of problem:
Error in header file libio.h (gcc version 3.2 from redhat)

gcc -DHAVE_CONFIG_H -I. -I. -I.. -I/usr/local/kde/include
-I/usr/local/qt-3.0.5/include -I/usr/X11R6/include  -DQT_NO_ASCII_CAST
-UQT_NO_COMPAT -O3 -DQT_THREAD_SUPPORT  -D_REENTRANT  -O2  -c `test -f ktrace.c
|| echo './'`ktrace.c
In file included from /usr/include/stdio.h:72,
                 from ktrace.c:40:
/usr/include/libio.h:340: parse error before "attribute_hidden"
/usr/include/libio.h:341: parse error before "attribute_hidden"
/usr/include/libio.h:342: parse error before "attribute_hidden"
make[2]: ** [ktrace.o] Erro 1
make[2]: Saindo do diretsrio `/tmp/download/kde/kdesdk-3.0.4/kmtrace'
make[1]: ** [all-recursive] Erro 1
make[1]: Saindo do diretsrio `/tmp/download/kde/kdesdk-3.0.4'
make: ** [all] Erro 2


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Download kde-3.0.4 from ftp.kde.org
2.unbzip2 and tar xvf (make and install arts and kdelibs before)
3.make
	

Actual Results:  Do not compile

Expected Results:  Compile

Additional info:

The instalation have all updates from hedhat
Comment 1 Need Real Name 2002-10-10 14:17:43 EDT
I want install kde from kde.org because redhat-kde do not show all my fonts,
helvetic, adobe, urw, etc.
Comment 2 Ngo Than 2002-10-15 05:50:45 EDT
hmm, there is a small patch file in kdesdk srpm. You have to apply it.

Note You need to log in before you can comment on or make changes to this bug.