Bug 756531 - rpmbuild needs option to skip '%clean' phase
Summary: rpmbuild needs option to skip '%clean' phase
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 16
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Upstream
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-23 20:44 UTC by Philip Prindeville
Modified: 2012-10-15 11:34 UTC (History)
4 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-10-15 11:34:26 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Bugzilla 755134 None CLOSED mock's --no-cleanup-after doesn't stop BUILDROOT from being emptied 2019-05-13 05:33 UTC

Internal Trackers: 755134

Description Philip Prindeville 2011-11-23 20:44:01 UTC
Description of problem:

It's sometimes useful to leave the resultant $RPM_BUILD_ROOT in place, especially so one can check the contents of manufactured files via sed scripts, or ownership, permissions, etc.

Skipping the %clean phase would allow this.

Version-Release number of selected component (if applicable):

rpm-build-4.9.1.2-1.fc16

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Toshio Kuratomi 2011-11-23 21:10:15 UTC
Reassigned to rpm which is where rpm-build is built from.  However, is there a reason that something like rpmbuild -bi  is not sufficient for you?

Comment 2 Philip Prindeville 2011-11-23 21:24:45 UTC
(In reply to comment #1)
> Reassigned to rpm which is where rpm-build is built from.  However, is there a
> reason that something like rpmbuild -bi  is not sufficient for you?

Because we'd also want the -bb phase done (the actual binary packaging).

There's a --clean option... why not a --noclean option?

Comment 3 Panu Matilainen 2012-08-02 09:18:45 UTC
Implemented upstream now.

Comment 4 Panu Matilainen 2012-10-15 11:34:26 UTC
rpm >= 4.10.1 in rawhide and F18 supports --noclean (and --nocheck). I've no plans to backport anything new to 4.9.x though, so closing.


Note You need to log in before you can comment on or make changes to this bug.