This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 7566 - printtool stair-step and EOF failure
printtool stair-step and EOF failure
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: printtool (Show other bugs)
6.1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 15:31 EST by mullins
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-07 17:02:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mullins 1999-12-03 15:31:58 EST
After configuring my printer (hp deskjet 697C)with the printtool, and
After selecting stairstep and EOF correction with fast textonly printing,
my printer printed text files correctly.  However, when I later rebooted,
the stair-step and EOF problems were back, and no amount of reconfiguring
with printtool worked.  Even more quirky was that the test page in
printtool printed fine.

Possible solution: In my spool file, /var/spool/lpd/lp, there were two
configuration files of the form .cfg.  One, general.cfg, had variables
declared with the export command. The other, textonly.cfg, where the
stair-stepping problem and the EOF problem should be resolved, had the
correct variables, but did not export them.  By editing this file so that
the variables were exported, it appears I've solved the problem.

ps: I hope these names of files are correct, I'm in windows because I've
not finished the PPP installation for my linux box.
Comment 1 Bernhard Rosenkraenzer 1999-12-08 10:02:59 EST
Thanks, this will be fixed in 6.2 (we're dropping printtool on behalf of a new
tool we're currently writing).
Comment 2 Crutcher Dunnavant 2000-08-08 11:23:51 EDT
I cannot duplicate this problem (stair steping fixes fine for me, and I've
looked at the code, don't see how it could break).
Closing.

Note You need to log in before you can comment on or make changes to this bug.