Bug 75660 - Installer kernel hangs
Installer kernel hangs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 16:00 EDT by Bill Carlson
Modified: 2008-08-01 12:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Carlson 2002-10-10 16:00:56 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020821

Description of problem:
Attempting to install on a Pentium II 300 MHz, Tyan S1682 Motherboard.
After booting from floppy, kernel gets to "ESR value before enabling vector:
00000004" and stops, with the floppy light lit. No change after 20 minutes.
I tried both bootnet and boot images, verified the floppy, used a different
disk, etc. Same floppy boots another machine just fine.
This particular machine is my test machine, same configuration runs Redhat 7.3
with no problems.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Cold Boot
2.Wait
3.Wait some more
	

Actual Results:  Same result everytime.

Expected Results:  Kernel should boot into install.

Additional info:

The particular board is dual processor with only a single CPU installed, so I
tried passing nosmp to the kernel. I also tried noapic just for grins.
Comment 1 Miloš Komarčević 2002-10-11 16:24:17 EDT
I can confirm this problem on the same hardware. No problems also with 7.3

On one boot attempt (w/ linux noprobe) I also got a repetative

APIC error on CPU0: 00(04)
Comment 2 Miloš Komarčević 2002-10-12 08:26:07 EDT
Correction:

my motherboard is Tyan S1686S (same as S1686D for dual PII,
but has only one CPU slot). Tried with both BIOS ver 2.0 and 2.08.

When trying norpobe or noapic  when booting from CD I sometimes
get a spontaneous reboot at the same spot in kernel init.
Comment 3 Bill Carlson 2002-10-15 14:46:42 EDT
This is definitely a problem with the installer kernel only. I pulled the old
trick of installing RH 8.0 on another machine, than transferring the hard drive
to the problem machine. Boots, no problem.
Comment 4 Need Real Name 2002-10-17 14:33:24 EDT
I had the same problem with a dual Intel PIII 1GHz setup (Asus CUV4X-D)
motherboard. I started the install with 'linux noapic' and it went smoothly from
there.  This particular problem has been documented in a SuSe knowledgebase <a
href="http://sdb.suse.de/en/sdb/html/jkoeke_cuv4x.html">here</a>.
Comment 5 Need Real Name 2002-10-17 23:03:16 EDT
I forgot to add that the RH7.3 install kernel, and the RH7.3 fresh install
kernel both work without problems.  The RH8.0 install kernel and the RH8.0 fresh
install kernel both fail.  The noapic option is required in order to get it to
work.  I don't have to disable MP1.4 support, though I'm not sure if the problem
manifests itself reliably once noapic is used.
Comment 6 Need Real Name 2002-10-24 16:54:15 EDT
I have the same problem with locking up when installing though mine stops after 
message "ESR value before enabling vector: 00000002".
However my MBoard is not SMP, just single CPU. It is a PCChips M825LMR with 
Duron 1.3Ghz. I made a boot floppy and switched the kernel for the one from 
RH7.3 and the floppy booted, ran mediacheck -ok and MD5 sums came out ok so its 
not the cd, but the floppy method locked up while partitioning with some debug 
messages unrelated to boot kernel.
NB. The same machine installs RH7.3 with no trouble at all.
Comment 7 John Hall 2002-10-28 10:36:32 EST
The RH8.0 installer also hangs on my system after the message "ESR value before
enabling vector: 00000002".  (I can install RH7.3 with no problems, though.)  I
have tried installing with 'linux noapic' with no success.  My motherboard is an
ECS K7VMM (KM266 NB and VT8233 SB) with an Athlon XP 1800+.
Comment 8 Need Real Name 2002-10-30 00:16:31 EST
I think this is the same bug as 
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=76542
and it seems that someone has made a script to create a new ISO using a 
recompiled kernel.
Im not sure if its complete yet but he says it will be soon.
Comment 9 Miloš Komarčević 2002-11-05 07:19:57 EST
I've used the script proposed  at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=76542
to build a new boot floppy (I've just commented out the bits for building the
whole CD1 as
I didn't have room on the haddrive) with APIC stuff in the kernel disabled, and
I was able to
install, and I am now running 8.0.
Comment 10 Bugzilla owner 2004-09-30 11:40:02 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.