Bug 75664 - glibc-2.2.4-30 and mysql-3.23.xx are not working together
Summary: glibc-2.2.4-30 and mysql-3.23.xx are not working together
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mysql (Show other bugs)
(Show other bugs)
Version: 7.2
Hardware: i686 Linux
medium
high
Target Milestone: ---
Assignee: Patrick Macdonald
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-10 20:31 UTC by Cyril Zlachevsky
Modified: 2007-04-18 16:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-04 05:48:32 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cyril Zlachevsky 2002-10-10 20:31:29 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ru-RU; rv:1.1) Gecko/20020827

Description of problem:
I found incompatibilie with latest build of glibc for Red Hat Linux 7.2 and
mysql 3.23.52 server.
This problem same as Bug# 75290 and Bug# 75297 (Red Hat 7.3 glibc-2.2.5-40 and
mysql 3.23.xx)

Version-Release number of selected component (if applicable):
glibc-2.2.5-40

How reproducible:
Always

Steps to Reproduce:
1. update glibc to version 2.2.4-30
2. install mysql-server 3.23.xx
3. Start mysql server
mysql_server# service mysqld start
3. from another mashine try:
mysql_clinet$ mysql -p -u mysql_login -h mysql_hostname.com
4. Get mysql error message:
ERROR 2013: Lost connection to MySQL server during query



Actual Results:  mysqld crash (client see):
---cut---
$ mysql -p -u mysql_login -h mysql_hostname.com
Enter password:
ERROR 2013: Lost connection to MySQL server during query
---cut---


mysqld crash (in log file on mysql server /var/log/mysqld.log):
---cut---
021010 22:11:44  mysqld started
021010 22:11:44  InnoDB: Started
/usr/libexec/mysqld: Online!

Number of processes running now: 1
mysqld process hanging, pid 20882 - killed
021010 22:12:06  mysqld restarted
021010 22:12:07  InnoDB: Database was not shut down normally.
InnoDB: Starting recovery from log files...
InnoDB: Starting log scan based on checkpoint at
InnoDB: log sequence number 0 174271324
InnoDB: Doing recovery: scanned up to log sequence number 0 174271324
021010 22:12:07  InnoDB: Flushing modified pages from the buffer pool...
021010 22:12:07  InnoDB: Started
/usr/libexec/mysqld: Online!
021010 22:19:12  /usr/libexec/mysqld: normal shutdown

021010 22:19:12  InnoDB: Starting shutdown...
021010 22:19:13  InnoDB: Shutdown completed
021010 22:19:13  /usr/libexec/mysqld: disconnect done

021010 22:19:13  mysqld ended

021010 22:19:15  mysqld started
---cut---

Expected Results:  $ mysql -p -u mysql_login -h mysql_hostname.com
Enter password:
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 230 to server version: 3.23.52

Type 'help;' or '\h' for help. Type '\c' to clear the buffer.

mysql>


Additional info:

This problem same as Bug# 75290 and Bug# 75297 (Red Hat 7.3 glibc-2.2.5-40 and
mysql 3.23.xx)

Comment 1 lbower 2002-10-18 01:00:37 UTC
RHN users who have applied all recent 'critical' patches may experience 
segmentation faults when accessing MySQL via a remote client (accessing 
databases @localhost seems OK) as described by mazay@phone.dn.ua/bug75664. I 
have experienced this issue with MySQL3.23.41-1 and 3.23.49-3 on RedHat 7.2 and 
8.0

The solution is to upgrade to MySQL version 3.23.53. There are currently no 
RedHat rpms available for this new release, but linux binaries are available at 
mysql.com.

Please supply a RedHat MySQL3.23.53 rpm via the RedHat network as soon as 
possible.

Comment 2 Need Real Name 2002-10-18 02:18:37 UTC
This problem caused me a lot of headaches today and I had to spend a lot of 
time diagnosing what turned out to be a bot very obvious fault with mysql.

The problem was thta I upgraded glibc last week, but mysql only displayed the 
symptons today ???

Why has it taken so long for redhat to produce the new rpms for mysql and 
release a bugfix ???

This problem is really widespread - seacrh in google groups for 'Lost 
connection to MySQL server during query' ...

Lance


Comment 3 Cyril Zlachevsky 2002-10-18 13:19:35 UTC
I test newest MySQL 3.23.53 (build from sources). 
Problem with glibc-2.2.4-30 in version MySQL 3.23.53 still exist.


Comment 4 Jason Corley 2002-10-18 18:51:56 UTC
I have had this exact same problem and adding the client machines to /etc/hosts
as suggested in bug number 76111 fixed the problem (obviously temporarily). 
This is a 7.2 machine fully patched running mysqld from Red Hat RPMS.
Jason

Comment 5 Cyril Zlachevsky 2002-11-25 23:14:04 UTC
in glibc-2.2.4-31 problem resolved


Note You need to log in before you can comment on or make changes to this bug.