Bug 75666 - PgUp/PgDn keys not working in xterm
PgUp/PgDn keys not working in xterm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rootfiles (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-10 17:08 EDT by Carlos Rodrigues
Modified: 2014-03-16 22:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-22 23:21:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Rodrigues 2002-10-10 17:08:16 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
When the num lock key is off I can't get the PgDn and PgUp keys to work properly
in xterm. In joe and such they don't work, except as said, if num lock is on.
For root, as by default his .Xresources defines PgDn and PgUp as prior/next, I
can't get them to work even if num lock is on. The workaround is of course
obvious but nevertheless it is rather annoying.

How reproducible:
Always

Steps to Reproduce:
1.Open xterm
2.Open joe with some text file
3.Try to scroll down using PgDn
4.Turn on num lock
5.Try to scroll down again
	

Actual Results:  After 3 nothing happens. After 5 it works.
Comment 1 Carlos Rodrigues 2002-10-11 15:48:24 EDT
With the default config this only happens to root because of the
<KeyPress>Prior/Next lines in .Xresources not with other users (was happening to
me because I had pasted some of root's .Xresources definitions to
/etc/X11/Xresources). Anyway with this config root isn't able to use PgUp/PgDn
except to scroll back and forth between xterm's pages themselves.

I guess this belongs to rootfiles then.
Comment 2 Mike A. Harris 2002-10-12 09:42:18 EDT
All xterm bug reports should be filed directly to XFree86.org, as Red Hat
does not support xterm.  xterm is provided only for end user convenience.
The preferred terminals are gnome-term and konsole.

You can report your bug to xterm developers by emailing xfree86@xfree86.org
Comment 3 Carlos Rodrigues 2002-10-12 15:39:56 EDT
Since this turned out to be (IMHO) merely a config file problem with the
.Xresources from redhat's rootfiles package I think there is nothing to report
to XFree86.org then.
Comment 4 Carlos Rodrigues 2002-10-17 06:03:04 EDT
As I mentioned previously, I think the problem is in the .Xresources file that
Red Hat distributes in the rootfiles package not xterm, so and also because it
is so easily fixed with no loss of functionality (scroll in xterm with
Shift-PgUp/Dn instead of only PgUp/Dn) I'm reopening the bug.
Comment 5 Mike A. Harris 2002-10-17 06:34:43 EDT
Reassigning to package owner.
Comment 6 Carlos Rodrigues 2003-04-13 15:43:21 EDT
Same problem in Red Hat 9.
Comment 7 Carlos Rodrigues 2004-07-10 13:16:51 EDT
Same problem in Fedora Core 2.
Comment 8 Bill Nottingham 2004-09-22 23:21:17 EDT
Removing .Xresources; there's no reason for it to be different for
root than for other users.

Note You need to log in before you can comment on or make changes to this bug.