This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 756666 - anaconda has no support for btrfs subvolumes
anaconda has no support for btrfs subvolumes
Status: CLOSED DUPLICATE of bug 689517
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 02:55 EST by Eric Hopper
Modified: 2011-11-24 02:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-24 02:59:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eric Hopper 2011-11-24 02:55:12 EST
When installing Fedora via the Anaconda graphical installer there is extensive support for creating lvm2 volumes groups and logical volumes. But there is no support for doing any similar operations with btrfs. btrfs is treated as purely a filesystem type and nothing more.

btrfs of course supports subvolumes, snapshots, multiple physical volumes arranged in a RAID configuration and many other useful things. But there is no way to make use of these things when doing an install via Anaconda.

This is particularly vexing to me as I've been wanting to upgrade into a snapshot of my original root subvolume. Also, I've been wanting to mount a particular subvolume as the root filesystem without having to set a 'default subvolume' in btrfs.

This is a feature request. But I think that this is a more important feature for the 'default btrfs filesystem' goal than even fsck is.
Comment 1 Eric Hopper 2011-11-24 02:59:30 EST

*** This bug has been marked as a duplicate of bug 689517 ***

Note You need to log in before you can comment on or make changes to this bug.