Bug 756670 - mount: norelatime is being ignored
mount: norelatime is being ignored
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: util-linux (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-24 03:32 EST by Need Real Name
Modified: 2011-11-27 14:58 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-24 06:50:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2011-11-24 03:32:08 EST
# mount |grep /boot
/dev/sda1 on /boot type ext3 (rw,relatime,seclabel,user_xattr,barrier=1,nodelalloc,data=ordered)

# mount /dev/sda1 /boot/ -onorelatime,remount

# mount |grep /boot
/dev/sda1 on /boot type ext3 (rw,relatime,seclabel,user_xattr,barrier=1,nodelalloc,data=ordered)

The same happens if I don't use remount. The same happens if I specify norelatime instead of defaults in /etc/fstab.

There is no way not to use norelatime.
Comment 1 Karel Zak 2011-11-24 06:50:05 EST
Did you read mount(8) man page?

# findmnt /boot
TARGET SOURCE    FSTYPE OPTIONS
/boot  /dev/sda1 ext4   rw,relatime,user_xattr,barrier=1,data=ordered

# mount -o remount,strictatime /boot

# findmnt /boot
TARGET SOURCE    FSTYPE OPTIONS
/boot  /dev/sda1 ext4   rw,user_xattr,barrier=1,data=ordered


The 'norealatime' only removes MS_RELATIME from the syscall mount(2) flags, so kernel will follow the default -- the default is realatime :-) You have to use strictatime to overwrite the default and enable full atime updates.
Comment 2 Need Real Name 2011-11-27 14:58:43 EST
This seems a little counter-intuitive.

So when I explicitly state the opposite of a mount option, I don't get it?

Should this also fail because rw is default?
mount -o remount,ro

Note You need to log in before you can comment on or make changes to this bug.