Bug 756704 - ipa-client configuration fails to join KDC realm on[ RHEL 5.8] with an error -- "RPC failed at server"
ipa-client configuration fails to join KDC realm on[ RHEL 5.8] with an error ...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xmlrpc-c (Show other bugs)
5.8
x86_64 Linux
unspecified Severity unspecified
: rc
: ---
Assigned To: Rob Crittenden
IDM QE LIST
: Reopened
Depends On:
Blocks: 758797
  Show dependency treegraph
 
Reported: 2011-11-24 05:59 EST by Kaleem
Modified: 2012-06-27 00:51 EDT (History)
5 users (show)

See Also:
Fixed In Version: xmlrpc-c-1.16.24-1206.1840.3.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:21:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 3 Rob Crittenden 2011-11-28 15:18:39 EST
Re-opened, re-assigning to xmlrpc-c component.

IPA enrollment is failing with xmlrpc-c-1.16.24-1206.1840.2.el5.x86_64 but succeeds with xmlrpc-c-1.16.24-1206.1840.el5_7.4.x86_64 because the ticket is not being delegated.

I think it is failing because the BuildRequires isn't setting a minimum to a version of curl-devel that defines HAVE_CURL_GSSAPI_DELEGATION.
Comment 4 Rob Crittenden 2011-11-29 16:52:33 EST
Added BuildRequires on curl-devel >= 7.15.5-15
Comment 6 Vojtech Vitek 2011-11-30 08:05:48 EST
Added Requires on curl >= 7.15.5-15 to xmlrpc-c-client, xmlrpc-c-client++ and xmlrpc-c-apps subpackages.
Comment 8 errata-xmlrpc 2012-02-21 00:21:19 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0179.html

Note You need to log in before you can comment on or make changes to this bug.