Bug 756803 - make_catalog_backup.pl mysql fails to create proper .my.conf and catalog backups failing
Summary: make_catalog_backup.pl mysql fails to create proper .my.conf and catalog bac...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bacula
Version: 6.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukáš Nykrýn
QA Contact: Tomas Dolezal
URL:
Whiteboard:
Depends On:
Blocks: 951578
TreeView+ depends on / blocked
 
Reported: 2011-11-24 16:18 UTC by Ed Brand
Modified: 2013-04-12 14:00 UTC (History)
4 users (show)

Fixed In Version: bacula-5.0.0-10.el6
Doc Type: Bug Fix
Doc Text:
Cause: Typo in perl script which generate my.conf Consequence: Port variable was not set correctly. Fix: Replace port=%args{db_port} -> port=$args{db_port} Result: Port is correctly written in conf file.
Clone Of:
: 951578 (view as bug list)
Environment:
Last Closed: 2012-11-19 04:15:19 UTC
Target Upstream Version:


Attachments (Terms of Use)
myconf.patch (351 bytes, patch)
2011-11-24 16:20 UTC, Ed Brand
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1469 normal SHIPPED_LIVE bacula bug fix update 2012-11-19 09:14:28 UTC

Description Ed Brand 2011-11-24 16:18:39 UTC
Description of problem:
/usr/libexec/bacula/make_catalog_backup.pl fails to create proper /var/spool/bacula/.my.cnf

Version-Release number of selected component (if applicable):
bacula-director-common-5.0.0-9

How reproducible:
Always


Steps to Reproduce:
1. Start catalog backup using mysql using RunBeforeJob = "/usr/libexec/bacula/make_catalog_backup.pl MyCatalog"
2. Watch job fail

  
Actual results:
/var/spool/bacula/.my.cnf
[client]
host=127.0.0.1
user=bacula
password=******
port=%args{db_port}

Expected results:
/var/spool/bacula/.my.cnf
[client]
host=127.0.0.1
user=bacula
password=******
port=3306


Additional info:
See attached myconf.patch for /usr/libexec/bacula/make_catalog_backup.pl

Comment 1 Ed Brand 2011-11-24 16:20:20 UTC
Created attachment 535967 [details]
myconf.patch

Comment 4 Suzanne Yeghiayan 2012-02-14 23:21:04 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 11 errata-xmlrpc 2012-11-19 04:15:19 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1469.html


Note You need to log in before you can comment on or make changes to this bug.