Bug 756866 - MacBookPro6,2: kernel: IRQ handler type mismatch for IRQ 0
Summary: MacBookPro6,2: kernel: IRQ handler type mismatch for IRQ 0
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c48c5e5b69c78073c9624dc0d64...
Keywords:
: 769427 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-24 22:25 UTC by joshua
Modified: 2012-04-04 16:17 UTC (History)
7 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-04-04 16:17:22 UTC


Attachments (Terms of Use)
File: smolt_data (3.83 KB, text/plain)
2011-11-24 22:25 UTC, joshua
no flags Details
dmesg output (96.82 KB, text/plain)
2011-12-05 18:54 UTC, joshua
no flags Details
acpidump (160.84 KB, text/plain)
2011-12-05 20:34 UTC, joshua
no flags Details

Description joshua 2011-11-24 22:25:20 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.1-2.fc16.x86_64 root=/dev/mapper/VolGrp00-f16_root ro rd.md=0 rd.dm=0 rd.luks.uuid=luks-8b11dfff-048a-4f4d-8b42-839d17404a06 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rd.lvm.lv=VolGrp00/f16_root rhgb rd.lvm.lv=VolGrp00/swap LANG=en_US.UTF-8
comment:        have no idea what caused this
kernel:         3.1.1-2.fc16.x86_64
reason:         IRQ handler type mismatch for IRQ 0
time:           Thu 24 Nov 2011 09:20:36 PM EST

smolt_data:     Text file, 3927 bytes

backtrace:
:IRQ handler type mismatch for IRQ 0
:current handler: timer
:Pid: 733, comm: modprobe Not tainted 3.1.1-2.fc16.x86_64 #1
:Call Trace:
: [<ffffffff810b1d76>] __setup_irq+0x39e/0x432
: [<ffffffff81119728>] ? kmem_cache_alloc_trace+0xb3/0xc5
: [<ffffffffa026899d>] ? ips_adjust+0x35a/0x35a [intel_ips]
: [<ffffffff810b1ef4>] request_threaded_irq+0xea/0x116
: [<ffffffffa026938e>] ips_probe+0x3a4/0x5e7 [intel_ips]
: [<ffffffff8123fd07>] local_pci_probe+0x44/0x75
: [<ffffffff8124086a>] pci_device_probe+0xd0/0xff
: [<ffffffff812dea37>] driver_probe_device+0x131/0x213
: [<ffffffff812deb73>] __driver_attach+0x5a/0x7e
: [<ffffffff812deb19>] ? driver_probe_device+0x213/0x213
: [<ffffffff812ddabf>] bus_for_each_dev+0x53/0x89
: [<ffffffff812de616>] driver_attach+0x1e/0x20
: [<ffffffff812de23a>] bus_add_driver+0xd1/0x224
: [<ffffffffa026c000>] ? 0xffffffffa026bfff
: [<ffffffff812df017>] driver_register+0x98/0x105
: [<ffffffffa026c000>] ? 0xffffffffa026bfff
: [<ffffffff8124112d>] __pci_register_driver+0x56/0xc1
: [<ffffffffa026c000>] ? 0xffffffffa026bfff
: [<ffffffffa026c01e>] ips_init+0x1e/0x20 [intel_ips]
: [<ffffffff81002099>] do_one_initcall+0x7f/0x136
: [<ffffffff8108a595>] sys_init_module+0x88/0x1d0
: [<ffffffff814bd902>] system_call_fastpath+0x16/0x1b

event_log:
:2011-11-24-17:23:47> Smolt profile successfully saved
:2011-11-24-17:24:12> Submitting oops report to http://submit.kerneloops.org/submitoops.php
:2011-11-24-17:25:16  Kernel oops has not been sent due to Couldn't connect to server
:2011-11-24-17:25:16* (exited with 1)

Comment 1 joshua 2011-11-24 22:25:25 UTC
Created attachment 536065 [details]
File: smolt_data

Comment 2 Chuck Ebbert 2011-11-28 17:28:49 UTC
The ips driver is trying to use interrupt 0, which is not allowed. This should never happen, maybe there is something wrong with the hardware? What was the last kernel version that worked?

Comment 3 joshua 2011-11-28 18:02:04 UTC
This is a MacBook Pro.  Fedora 15 never did this.  I don't think the first kernel or two in F16 did either.

Comment 4 Josh Boyer 2011-12-05 17:15:17 UTC
can you attach the full dmesg output and acpidump for this machine?

Comment 5 joshua 2011-12-05 18:54:25 UTC
Created attachment 541043 [details]
dmesg output

Comment 6 joshua 2011-12-05 18:55:12 UTC
dmesg output attached... what is acpidump?  It doesn't appear to be command in F16

Comment 7 Josh Boyer 2011-12-05 19:25:56 UTC
(In reply to comment #6)
> dmesg output attached... what is acpidump?  It doesn't appear to be command in
> F16

acpidump is a command provided by the pmtools package.  If you install that, you should be able to run it as root.

So your machine seems to have multiple APIC tables:

[    0.000000] ACPI: BIOS bug: multiple APIC/MADT found, using 0
[    0.000000] ACPI: If "acpi_apic_instance=2" works better, notify linux-acpi@vger.kernel.org

Can you try passing acpi_apic_instance=2 on the kernel command line and see if the problem gets better?

Comment 8 joshua 2011-12-05 20:34:42 UTC
Created attachment 541074 [details]
acpidump

Comment 9 joshua 2011-12-05 20:36:29 UTC
attached acpidump.

This is a 2010 Macbook Pro.  Is this multiple APIC tables a known feature/issue for Macbook Pro models?

I'll try the kernel command-line args you suggest.

Comment 10 Mads Kiilerich 2011-12-13 16:13:37 UTC
This report seems to be with a BIOS boot of MacBookPro6,2.

I saw the same when booting the same model from USB with EFI (and nomodeset).

Comment 11 joshua 2011-12-23 15:59:41 UTC
*** Bug 769427 has been marked as a duplicate of this bug. ***

Comment 12 joshua 2011-12-23 16:00:29 UTC
acpi_apic_instance=2 doesn't seem to help me.  See BZ # 769427

Comment 13 Josh Boyer 2012-03-01 14:07:36 UTC
Is this still happening with the 3.2.7 or newer kernels?

Comment 14 joshua 2012-03-02 17:13:06 UTC
Sadly yes, see 769427 which I just created.

Comment 15 Dave Jones 2012-03-22 17:14:52 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 16 Dave Jones 2012-03-22 17:17:04 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 17 Dave Jones 2012-03-22 17:25:43 UTC
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.

Comment 18 joshua 2012-03-28 13:53:16 UTC
Sadly no.  I just did an abrt report upload for this bug on the 3.3.0 kernel.  Same error.

Comment 19 Josh Boyer 2012-03-28 14:27:18 UTC
I just pushed a fix of sorts for this earlier today.  It should be in the next f16 update.

Comment 20 Josh Boyer 2012-04-04 16:17:22 UTC
This should be fixed with the latest update.


Note You need to log in before you can comment on or make changes to this bug.