Bug 7569 - tcpdump options dont work.
tcpdump options dont work.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: tcpdump (Show other bugs)
6.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 16:06 EST by musman
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-22 09:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description musman 1999-12-03 16:06:24 EST
I have identified a problem trying to use tcpdump.

The following command works just fine under redhat 5.x, Solaris, IRIX,
etc. but fails under several different installations of redhat 6.0. I
haven't yet had a chance to replicate it under redhat 6.1.

>tcpdump '(icmp[0] == 8 ) or (port sunrpc)'
tcpdump: unknown port 'sunrpc'

I compiled the same version of tcpdump source under both releases of
redhat, and the redhat 5.x version even runs under 6.0, but I get the
same error as above.
Comment 1 Jeff Johnson 1999-12-03 16:27:59 EST
There appears to be a getservbyname call that has been taken out, probably
to speed up tcpdump performance.

Meanwhile try putting the port number in numerically (use "111" instead of
"sunrpc"). I suspect that will work ...
Comment 2 Jeff Johnson 1999-12-22 09:49:59 EST
Your command works in tcpdump-3.4-17 from Raw Hide. If it still doesn't
work for you, check your /etc/nsswithc.conf setup.

Note You need to log in before you can comment on or make changes to this bug.