Bug 75709 - strace -p leaves attached process in stopped state
strace -p leaves attached process in stopped state
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: strace (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Roland McGrath
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 07:06 EDT by Han Holl
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-10 18:11:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Han Holl 2002-10-11 07:06:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20021002

Description of problem:
See summary. Do strace -p on some daemon, detach with ctrl/c,
and do cat /proc/$(pidof daemon)/status
You see State: stopped
killall -CONT daemon continues the daemon.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.See description
2.
3.
	

Additional info:

This happens with strace-4.4-4 and also with strace-4.4-8 (rawhide)
I'm amazed that no bug has been filed for this yet.
I've gone back tp strace-4.3-2 wich works fine.
Comment 1 Charlie Brady 2002-11-27 12:53:56 EST
I get exactly the same thing, and am also amazed that this hasn't been reported
more widely:

sh-2.05a# ps fax | grep xinetd
 1200 ?        S      0:00 xinetd -stayalive -reuse -pidfile
/var/run/xinetd.pidsh-2.05a# strace -p1200
select(8, [3 5 6 7], NULL, NULL, NULL <unfinished ...>
sh-2.05a# ps fax | grep xinetd
 1200 ?        T      0:00 xinetd -stayalive -reuse -pidfile
/var/run/xinetd.pidsh-2.05a# kill -CONT 1200
sh-2.05a# ps fax | grep xinetd
 1200 ?        S      0:00 xinetd -stayalive -reuse -pidfile
/var/run/xinetd.pidsh-2.05a# 

sh-2.05a# rpm -q strace ; rpm -q kernel
strace-4.4-4
kernel-2.4.18-5
sh-2.05a#
Comment 2 Charlie Brady 2002-11-27 12:56:08 EST
I don't see anything related in the strace changelog, but this might have been
cleared up in latest version from rawhide (at least when compiled from src
locally - I didn't try the binary from RedHat):

[root@vmware-charlieb root]# rpm -Uhv strace-4.4-9.1.i386.rpm 
Preparing...                ########################################### [100%]
   1:strace                 ########################################### [100%]
ps fax |[root@vmware-charlieb root]# ps fax | grep xinetd
 1167 ?        S      0:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid
2246 pts/1    S      0:00          \_ grep xinetd
[root@vmware-charlieb root]# strace -p1167
select(7, [3 5 6], NULL, NULL, NULL <unfinished ...>
[root@vmware-charlieb root]# ps fax | grep xinetd
 1167 ?        S      0:00 xinetd -stayalive -reuse -pidfile /var/run/xinetd.pid
2249 pts/1    S      0:00          \_ grep xinetd
[root@vmware-charlieb root]# 
Comment 3 Roland McGrath 2002-12-17 23:19:34 EST
*** Bug 79782 has been marked as a duplicate of this bug. ***
Comment 4 Roland McGrath 2002-12-17 23:20:34 EST
I have a fix for this in the current upstream version and we will have
an errata version fixing it before too long.

Comment 5 Roland McGrath 2003-01-10 18:11:05 EST
Version 4.4.91-1 should work fine.
Comment 6 Han Holl 2003-01-13 09:25:34 EST
Works for me now.

Note You need to log in before you can comment on or make changes to this bug.