Bug 75711 - Htmlview ignores Gnome default
Htmlview ignores Gnome default
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: htmlview (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 08:56 EDT by fred-m
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-06 08:54:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fred-m 2002-10-11 08:56:53 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Htmlview is the default handler for html in Gnome, and its icon figures
prominently on the Gnome toolbar, so most users will probably use this icon.
However, htmlview does not consider the Gnome default (set in Extras ->
Preferences -> Preferred applications). Since the default for both htmlview and
Gnome is Mozilla, htmlview works with Gnome out of the box. But, if I change the
Gnome default (to, say, Galeon), and then click the htmlview icon in Gnome, I
still get Mozilla.

Setting my ~/.htmlviewrc file to
export X11BROWSER=/usr/bin/galeon
solves the problem.

I think that the simplest way to solve this problem for now is to have the
"Preferred applications" application write the browser chosen to the
~/.htmlviewrc file. (Not sure if it will work on KDE).

(Think of it, this is two bugs. Changing the default browser in the "Preferred
applications" should change also the html and other setups in Preferences ->
File Types and Programs also.)



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a freshly updated, or newly installed, Red Hat 8.0 (BTW, mine was
upgraded from 7.3)
2. Change the Extras -> Preferences -> Preferred applications Web browser to Galeon
3. Click the htmlview icon on the Gnome toolbar
	

Actual Results:  Mozilla, not Galeon, will be started

Expected Results:  Galeon is started

Additional info:

I'm registering it as a bug, not RFE, since it is very confusing for the
end-user. Whether it should be classified as an htmlview bug depends on the
solution that you choose.
Comment 1 Need Real Name 2002-10-12 23:53:25 EDT
i would also at the very least suggest the Preferred applications program create
a correct ~/.htmlviewrc
Comment 2 Tim Waugh 2002-12-06 08:54:35 EST
Fixed package is 2.0.0-8, which will shortly appear in rawhide.
Comment 3 fred-m 2002-12-16 05:00:00 EST
Tested htmlview-2.0.0-9, and works nicely. Thanks!!!

Note You need to log in before you can comment on or make changes to this bug.