This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 757127 - abrt-dump-oops: Can't open '/etc/abrt/abrt.conf' ... but it exists
abrt-dump-oops: Can't open '/etc/abrt/abrt.conf' ... but it exists
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jiri Moskovcak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ABRTF18
  Show dependency treegraph
 
Reported: 2011-11-25 09:31 EST by Mads Kiilerich
Modified: 2015-02-01 17:55 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-13 04:04:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mads Kiilerich 2011-11-25 09:31:06 EST
On boot (with kernel oops) I get /var/log/messages:

Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Found oopses: 1
Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Can't open '/etc/abrt/abrt.conf'
Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Creating dump directories
Nov 25 15:22:37 fladmast abrtd: Directory 'oops-2011-11-25-15:22:37-924-0' creation detected
Nov 25 15:22:37 fladmast abrt-dump-oops: Reported 1 kernel oopses to Abrt
Nov 25 15:22:37 fladmast abrtd: Can't open file '/var/spool/abrt/oops-2011-11-25-15:22:37-924-0/uid': No such file or directory

but

[root@fladmast log]# ll /etc/abrt/abrt.conf 
-rw-r--r--. 1 root root 659 Nov  5 19:49 /etc/abrt/abrt.conf
[root@fladmast log]# ll -Z /etc/abrt/abrt.conf 
-rw-r--r--. root root system_u:object_r:abrt_etc_t:s0  /etc/abrt/abrt.conf

abrt-addon-kerneloops-2.0.6-1.fc16.x86_64
Comment 1 Jiri Moskovcak 2011-11-28 07:21:09 EST
(In reply to comment #0)
> On boot (with kernel oops) I get /var/log/messages:
> 
> Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Found oopses: 1
> Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Can't open
> '/etc/abrt/abrt.conf'

- this part is weird

> Nov 25 15:22:37 fladmast abrt-dump-oops[924]: abrt-dump-oops: Creating dump
> directories
> Nov 25 15:22:37 fladmast abrtd: Directory 'oops-2011-11-25-15:22:37-924-0'
> creation detected
> Nov 25 15:22:37 fladmast abrt-dump-oops: Reported 1 kernel oopses to Abrt
> Nov 25 15:22:37 fladmast abrtd: Can't open file
> '/var/spool/abrt/oops-2011-11-25-15:22:37-924-0/uid': No such file or directory
> 

- this part is dupe of #752450
Comment 2 Jiri Moskovcak 2012-08-10 06:12:48 EDT
Do you still experience this problem? If yes, is there any AVC realated to abrt-dump-oops in /var/log/audit/audit.log?
Comment 3 Mads Kiilerich 2012-08-10 08:06:32 EDT
No, I haven't noticed it recently ... but I have also not seen so many crashes recently ;-)
Comment 4 Jiri Moskovcak 2012-08-13 04:04:04 EDT
Thanks for the info. I believe it was caused by a wrong selinux policy which should be already fixed.

Note You need to log in before you can comment on or make changes to this bug.