This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 75715 - Timestamps on jobs are wrong
Timestamps on jobs are wrong
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: cups (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 09:53 EDT by Need Real Name
Modified: 2007-04-18 12:47 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-09 11:43:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-10-11 09:53:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0; AT&T CSM6.0; 
T312461)

Description of problem:
The timestamps on jobs printed with cups are wrong.  In my case the time is 5 
hours later than it should be.  Is cups perhaps showing timestamps in UTC?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Go to cups printer admin
2. Print a test page
3. Look at the timestamp in the active or completed jobs
	

Actual Results:  Timestamps are 5 hours ahead of actual time job is/was printed.

Expected Results:  Timestamp should reflect the time the job was printed in the 
server timezone.

Additional info:

   HPNAT-67  Test Page    15k  cancelled at
   Fri Oct 11 13:44:40 2002  Restart Job

   Show Active Jobs
     _________________________________________________________________
[####]# date
Fri Oct 11 08:49:57 CDT 2002
[####]# cat /etc/sysconfig/c
clock    console
[####]# cat /etc/sysconfig/clock
ZONE="America/Chicago"
UTC=false
ARC=false
Comment 1 Tim Waugh 2002-10-11 10:03:56 EDT
Yes, that's UTC.
Comment 2 Tim Waugh 2002-10-11 10:26:30 EDT
Confusingly, 'lpstat' shows the local time zone, but also omits time zone 
information from its output.
Comment 3 Tim Waugh 2004-12-09 11:43:03 EST
Seems to be intentional.

Note You need to log in before you can comment on or make changes to this bug.