Bug 757174 - Cannot install glib2-devel.i686 parallel to glib2-devel.x86_64
Cannot install glib2-devel.i686 parallel to glib2-devel.x86_64
Status: CLOSED DUPLICATE of bug 718404
Product: Fedora
Classification: Fedora
Component: glib2 (Show other bugs)
15
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Matthias Clasen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 11:57 EST by Simon Lewis
Modified: 2012-03-21 08:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-21 08:07:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Lewis 2011-11-25 11:57:00 EST
For the multimedia application FeSTige i need to install the 32bit glib2-devel package in addition to the 64 bit version.

However, there are a 6-files in the 32bit package which colide with files in the 64bit version, see yum error message below:

Prüffehler bei Verarbeitung:
  file /usr/share/glib-2.0/gdb/glib.pyc from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
  file /usr/share/glib-2.0/gdb/glib.pyo from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyc from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
  file /usr/share/glib-2.0/gdb/gobject.pyo from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
  file /usr/share/systemtap/tapset/glib.stp from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
  file /usr/share/systemtap/tapset/gobject.stp from install of glib2-devel-2.28.8-1.fc15.i686 conflicts with file from package glib2-devel-2.28.8-1.fc15.x86_64
Comment 1 Alon Levy 2012-03-21 08:07:45 EDT
This is a duplicate of 718404 (I'm closing it not because I'm a developer of glib2 but because I have the same problem and noticed the duplicate bug, and the other is the first one with more comments too).

*** This bug has been marked as a duplicate of bug 718404 ***

Note You need to log in before you can comment on or make changes to this bug.