Bug 757198 - on boot kernel version not correctly displayed (grub2, kernel)
on boot kernel version not correctly displayed (grub2, kernel)
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 13:38 EST by Michel Duquaine
Modified: 2011-11-28 14:08 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 14:08:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michel Duquaine 2011-11-25 13:38:46 EST
Description of problem:

On boot, the display of the kernel version is not correct (echo 'Loading Fedora (3.1.1-1.fc16.x86_64)' instead of 3.1.2-1.fc16.x86_64)

Version-Release number of selected component (if applicable):
see [1] & [2] below

How reproducible:


Steps to Reproduce:
1. start the pc
2. check the kernel version that will be launched on the grub2 screen selection
3. check the kernel version displayed just after the grub2 screen selection 
  
Actual results:
(3.1.1-1.fc16.x86_64)

Expected results:
(3.1.2-1.fc16.x86_64)

Additional info:
[1]
$ uname -a
Linux apollo.localdomain 3.1.2-1.fc16.x86_64 #1 SMP Tue Nov 22 09:00:57 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

[2]
/boot/grub2/grub.cfg :
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.2-1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
        load_video
        set gfxpayload=keep
        insmod gzio
        insmod part_gpt
        insmod ext2
        set root='(hd0,gpt2)'
        search --no-floppy --fs-uuid --set=root 2659a567-d06a-4141-9537-d72b26d63c58
        echo 'Loading Fedora (3.1.1-1.fc16.x86_64)'
        linux   /vmlinuz-3.1.2-1.fc16.x86_64 root=/dev/mapper/vg_apollo-lv_root ro rd.md=0 rd.dm=0  KEYTABLE=be-latin1 rd.lvm.lv=vg_apollo/lv_swap quiet SYSFO
Comment 1 Josh Boyer 2011-11-28 09:06:11 EST
This sounds like a grubby/grub2 problem.
Comment 2 Brian Lane 2011-11-28 14:08:24 EST

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.