Bug 757235 - Kernel update doesn't correctly update the grub.cfg
Kernel update doesn't correctly update the grub.cfg
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grubby (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-25 18:03 EST by Terry Duell
Modified: 2011-11-28 14:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-11-28 14:09:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Terry Duell 2011-11-25 18:03:37 EST
Description of problem:
Kernel update updates grub.cfg menu entries, but doesn't update the echo 'Loading...' message

Version-Release number of selected component (if applicable):
kernel 3.1.2-1 update, but first noticed on kernel 3.1.1.-2 update

How reproducible:
For me, last 2 kernel updates have exhibited this behaviour

Steps to Reproduce:
1. install kernel update
2. reboot
3. 
  
Actual results:
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.2-1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root 13663d12-5659-4447-8c8f-661ea86aa3e1
	echo 'Loading Fedora (3.1.1-1.fc16.x86_64)'
	linux	/vmlinuz-3.1.2-1.fc16.x86_64 

Expected results:
### BEGIN /etc/grub.d/10_linux ###
menuentry 'Fedora (3.1.2-1.fc16.x86_64)' --class fedora --class gnu-linux --class gnu --class os {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_msdos
	insmod ext2
	set root='(hd0,msdos1)'
	search --no-floppy --fs-uuid --set=root 13663d12-5659-4447-8c8f-661ea86aa3e1
	echo 'Loading Fedora (3.1.2-1.fc16.x86_64)'
	linux	/vmlinuz-3.1.2-1.fc16.x86_64 

Additional info:
Comment 1 Brian Lane 2011-11-28 14:09:24 EST

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.