Bug 75729 - listinfo page does not show proper host name
listinfo page does not show proper host name
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: mailman (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 12:35 EDT by Joseph Tate
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-06 05:06:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joseph Tate 2002-10-11 12:35:17 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020606

Description of problem:
It appears that the hostname on the listinfo page is not using the value stored
in the mm_cfg.py file as it is being used on the admin page.  The listinfo page
seems to be using the hostname from the requesting url.

Version-Release number of selected component (if applicable): mailman-2.0.13-1


How reproducible:
Always

Steps to Reproduce:
1.Install Mailman
2.Setup the web access
3.Visit http://<host>/mailman/listinfo and http://<host>/mailman/admin noting
the differences in the header.
	

Actual Results:  The mailman/admin page matches the value in the mm_cfg.py file:
localhost.localdomain.  The mailman/listinfo page matches the calling url. 
Change mm_cfg.py, and only the admin page changes to match.

Expected Results:  mailman/admin and mailman/listinfo should both use
%DEFAULT_HOST_NAME from mm_cfg.py.

Additional info:
Comment 1 Florian La Roche 2004-06-06 05:06:12 EDT
Changing to a canonical name is more a web server config item.
Seems working fine with the current rpm to me, so closing this here.

Florian La Roche

Note You need to log in before you can comment on or make changes to this bug.