Bug 75730 - NEdit randomly spontaneously closes all windows after closing one
NEdit randomly spontaneously closes all windows after closing one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openmotif (Show other bugs)
1
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 12:36 EDT by Shawn Walker
Modified: 2007-11-30 17:10 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-08 05:33:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Shawn Walker 2002-10-11 12:36:41 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
NEdit randomly spontaneously closes all windows after closing an open file or
saving one sometimes. I'll have several files open for editing and then suddenly
out of nowhere, I get this error:

Starting program: /usr/X11R6/bin/nedit -server
Error: XtPopdown requires a subclass of shellWidgetClass

Program exited with code 01.


Version-Release number of selected component (if applicable):


How reproducible:
Sometimes

Steps to Reproduce:
1. Open nedit
2. Open several files, edit for a while, saving frequently and closing files

	

Actual Results:  Error: XtPopdown requires a subclass of shellWidgetClass

Program exited with code 01.


Expected Results:  The program should not exit.

Additional info:
Comment 1 Shawn Walker 2002-10-11 12:41:04 EDT
This may be related to this bug documented on the NEdit project site:

http://sourceforge.net/tracker/index.php?func=detail&aid=411092&group_id=11005&atid=111005

If so, they have a patch that fixes the problem.
Comment 2 Shawn Walker 2003-01-02 12:44:59 EST
Using the latest RPM from Rawhide this problem still exists. However, I've
narrowed it down to a mostly not so random case. Basically I usually run into it
with these steps:

Start nedit:
Open a file, make changes, save a few times. Make sure all your changes are
saved. Then:

Open another file without closing the current one using the current copy of
NEdit that's running. It spawns another NEdit window.

In the spawned window, make changes, save and then use the hot key shortcuts:
ALT+F (to bring up the file menu)
and then press C to close the current file.

Instead of closing the current file, it will often close *all* open nedit
windows. This appears to be a bug with NEdit's server mode. Because when I
manually start up a new copy of nedit for each file I want to edit, I never have
this problem.
Comment 3 Shawn Walker 2003-01-14 11:37:20 EST
Here's the error I get in the console when Nedit closes like this:

"Error: XtPopdown requires a subclass of shellWidgetClass"
Comment 4 Damien Miller 2003-04-04 04:12:22 EST
This bug is still present with Redhat 9.0. It has been suggested (on the Nedit
mailing list) that the problem is caused by a mismatch between the motif headers
and libraries at build time. See the thread starting here:

http://www.nedit.org/archives/discuss/2002-Nov/0091.html

It may also be related to the use of OpenMotif 2.2, nedit.org mentions problems
with that version:

http://www.nedit.org/about/news.shtml#191002

It would be good if this was cleared up, it is very frustrating when it happens.
Comment 5 Need Real Name 2003-09-14 10:04:07 EDT
This has been confirmed to be a problem with OpenMotif 2.2, which has numerous
other stability problems.  We have not been able to work around it yet, so we
recommned using OpenMotif 2.1, which is the most stable Motif available. 
OpenMotif 2.2 is "experimental" alpha-quality software, which is not a good
match for NEdit which is mature and stable.

See http://nedit.org/toolkit.shtml and
http://www.motifdeveloper.com/tips/tip22.html for more info.
Comment 6 Carlos Rodrigues 2003-12-01 23:28:18 EST
This happens to me in Fedora Core 1 also.
Comment 7 Tim Waugh 2003-12-02 04:45:48 EST
Openmotif bug -> changing component.
Comment 8 Thomas Woerner 2004-03-08 05:33:49 EST
Fixed in rawhide in rpm openmotif-2.2.2-17 or newer.

Note You need to log in before you can comment on or make changes to this bug.