Bug 75733 - invalid unicode characters cause directories to add to all playlists
Summary: invalid unicode characters cause directories to add to all playlists
Status: CLOSED UPSTREAM
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xmms (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Colin Walters
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-11 17:02 UTC by Chris Ricker
Modified: 2007-04-18 16:47 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 19:29:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dump of /export/fs/mp3s inode (16.00 KB, application/octet-stream)
2002-10-11 17:02 UTC, Chris Ricker
no flags Details

Description Chris Ricker 2002-10-11 17:02:14 UTC
Directories with invalid unicode characters get automagically added to *all*
playlists in xmms.

Here at work we have a NFS shared directory, /export/fs/mp3s, under which users
can put personal CDs they've ripped to listen to at work.

One of our users with questionable musical taste, ripped a CD, "Misty Eyed
Adventures", by an artist named Maire Brennan.  This was ripped under RH 7.1 or
7.2 in either C or ISO8859-1 or ISO8859-15 modes, creating a directory named

/export/fs/mp3s/Maire Brennan - Misty Eyed Adventures

Now, we have users running RHL 8.0.  When they access any other directory under
the /export/fs/mp3s directory (say, /export/fs/mp3s/White_Noise, for example) in
xmms, the files in /export/fs/mp3s/Maire Brennan - Misty Eyed Adventures
automatically get added to the XMMS playlist.

The problem appears to be that the a in Maire is encoded improperly for Unicode
-- on RHL 8 machines, this directory appears as M ire Brennan, and Nautilus even
warns that it's invalid Unicode.

I'll attach a dump of the /export/fs/mp3s directory inode.  The inode in
question (the Maire Brennan directory) is 13025284.

By itself, the change in encoding from 7.2 to 8.0 isn't a problem.  The problem
is that xmms is automatically adding this directory to all playlists. 
Presumably it's getting confused by the invalid unicode, but some of our users
are already using this bug in xmms for practical jokes....

Comment 1 Chris Ricker 2002-10-11 17:02:50 UTC
Created attachment 80024 [details]
dump of /export/fs/mp3s inode

Comment 2 Chris Ricker 2002-10-11 17:12:24 UTC
It definitely appears to be due to Unicode wackiness.  If the users run

LANG=C xmms &

then the badly encoded directory doesn't automagically get added to their playlists

Comment 3 Chris Ricker 2002-10-11 17:15:57 UTC
Hmm, bugzilla automatically stripped it.  The "a" in Maire above has an accent
above it.

Comment 4 Colin Walters 2004-09-27 19:29:18 UTC
Moved upstream here:
http://bugs.xmms.org/show_bug.cgi?id=1918


Note You need to log in before you can comment on or make changes to this bug.