Bug 75736 - How to (un)install RPM packages?!
How to (un)install RPM packages?!
Status: CLOSED DUPLICATE of bug 78996
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-packages (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
David Lawrence
:
: 77139 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 13:22 EDT by Noel Carneiro
Modified: 2007-04-18 12:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:49:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel Carneiro 2002-10-11 13:22:42 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; SunOS 5.7 sun4u)

Description of problem:
The default package manager program that is shipped with RH 8.0 doesn't show any
RPM package that is not within the distribution or is not in the default
categories. For instance, if you choose not to install NEdit or Wine during
installation, and install then later, it does not show anywhere. There is no GUI
to manage RPM packages!  Where is GnoRPM or KPackage?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Do not install a non distribution packege during RH 8.0 installation.
2. Install it later.
3. No mention of the program is shown.
	

Actual Results:  The package is installed, but you cannot see it listed. If you
want to upgrade or even uninstall it, you have to do it manually in the console
terminal.

Expected Results:  It should work with any RPM package, like the old GnoRPM
and/or KPackage.

Additional info:

The same problem applies when you update a package.
Comment 1 Jeremy Katz 2002-10-11 16:40:39 EDT
This is known and an all packages view is planned for a future release
Comment 2 Marius Andreiana 2002-10-18 12:24:52 EDT
it doesn't show manually installed packages which are part of the distribution too.

During install I didn't choose any development, but later I've manually installed
the gcc and kernel-source packages later. They don't show up as installed in
redhat-config-packages.
Comment 3 mxkennedy 2002-10-21 03:18:28 EDT
If I use the old GnoRPM or KPackage, will it work on redhat 8.0? 
Comment 4 Marius Andreiana 2002-10-21 08:33:12 EDT
If possible, please enhance gnorpm instead of dropping it for the future release.
Comment 5 Noel Carneiro 2002-10-21 13:07:14 EDT
KPackage doesn't install on RH 8.0. I haven't tried GnoRPM.
Comment 6 Noel Carneiro 2002-10-21 13:40:00 EDT
I think KPackage should be put back in future releases.
Comment 7 matteo porta 2002-10-29 14:22:36 EST
since redhat tools always use gtk, and gnome is the  preferred desktop, i'd
prefer  gnorpm instead of kpackage... please enhance gnorpm! (or write a better
one...)
Comment 8 Jeremy Katz 2002-11-01 12:34:50 EST
*** Bug 77139 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2002-12-31 02:50:31 EST

*** This bug has been marked as a duplicate of 78996 ***
Comment 10 Red Hat Bugzilla 2006-02-21 13:49:55 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.