Bug 757406 - Typo in grub.cfg
Typo in grub.cfg
Status: CLOSED DUPLICATE of bug 732654
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
16
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-26 15:56 EST by an0nymous
Modified: 2011-12-08 14:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-08 14:07:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
grub.cfg opened in a terminal window. (220.86 KB, image/jpeg)
2011-11-26 15:56 EST, an0nymous
no flags Details
Diff of grub2.cfg after updating the system. (1.94 KB, patch)
2011-12-08 10:10 EST, Jan Synacek
no flags Details | Diff

  None (edit)
Description an0nymous 2011-11-26 15:56:02 EST
Created attachment 536918 [details]
grub.cfg opened in a terminal window.

Nothing major, I installed the update for the 3.1.2-1.fc16.x86_64 kernel and noticed during the boot, when I selected the new kernel, grub said it was loading 3.1.1-2 instead of 3.1.2-1. I investigated and discovered a simple typo in the echo command that is issued in grub.cfg

It reads: 
echo 'Loading Fedora (3.1.1-2.fc16.x86_64)'

when it should read:
echo 'Loading Fedora (3.1.2-1.fc16.x86_64)'


I took a quick screen shot and attached it here.
Comment 1 Jan Synacek 2011-12-06 07:07:47 EST
The same happened after the update for the 3.1.4.1.fc16.x86_64.
Grub entry now reads:
echo 'Loading Fedora (3.1.2-1.fc16.x86_64)'

Should read:
echo 'Loading Fedora (3.1.4-1.fc16.x86_64)'
Comment 2 Vít Ondruch 2011-12-08 07:31:33 EST
The kernel update is calling "new-kernel-pkg" which in turn is using grubby to update the grub.cfg. Grubby takes the default menu entry as an template and updates it accordingly the new Kernel. 

Somewhere bellow this line [1], you can see that if the 'echo' line contains string 'Loading Linux', it is appropriately updated. However, yours line contains 'Loading Fedora', so it stays as it was.

The only question which remains is where the menu entry with 'Loading Fedora' came from. Unfortunately I cannot find it to understand this issue completely :( Calling $ grub2-mkconfig, which was presumably used during installation to prepare default grub.cfg, returns the 'Loading Linux' string.


[1] http://git.fedorahosted.org/git/?p=grubby.git;a=blob;f=grubby.c;h=38ca9acafb8cc1cbdbdced7adb12647d425bb3d2;hb=HEAD#l2961
Comment 3 Jan Synacek 2011-12-08 10:10:38 EST
Created attachment 542577 [details]
Diff of grub2.cfg after updating the system.
Comment 4 Jan Synacek 2011-12-08 10:15:33 EST
I was curious about this, so I tried again.

I installed fedora 16 64b version from the DVD and kept the original grub2.cfg file. Then I updated all the packages and created a diff against the new grub2.cfg.

Strangly enough, this time there were no typos. The 'Loading Fedora' string is still there though.

Hope this helps.
Comment 5 Mads Kiilerich 2011-12-08 14:07:22 EST

*** This bug has been marked as a duplicate of bug 732654 ***

Note You need to log in before you can comment on or make changes to this bug.