Bug 75743 - Designer segfaults on exit
Designer segfaults on exit
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: qt (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 15:22 EDT by Carlos Rodrigues
Modified: 2007-04-18 12:47 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-16 09:20:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -qi qt kdebase kdelibs output (3.04 KB, text/plain)
2002-10-11 17:38 EDT, Carlos Rodrigues
no flags Details

  None (edit)
Description Carlos Rodrigues 2002-10-11 15:22:37 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
After exiting from qt designer, I get a segmentation fault message.

How reproducible:
Always

Steps to Reproduce:
1.run designer
2.exit

	

Actual Results:  Segmentation fault.

Expected Results:  Should say nothing.
Comment 1 Ngo Than 2002-10-11 16:48:41 EDT
I cannot reproduce it on many local machines.

What does "rpm -qi qt kdebase kdelibs" say on your system?

Comment 2 Carlos Rodrigues 2002-10-11 17:38:42 EDT
Created attachment 80066 [details]
rpm -qi qt kdebase kdelibs output
Comment 3 Carlos Rodrigues 2002-10-16 09:10:13 EDT
It seems that this doesn't happen with the Bluecurve or Highcolor styles but it
happens with Keramik or dotNET (I'm using the latter).

I also couldn't reproduce it as root:
As root (su on an xterm as normal user) I had neither a .kde, .qt or any
configurations for qt or kde. I ran designer (with both bluecurve and dotNET)
and exited, it didn't segfault...
Comment 4 Carlos Rodrigues 2002-10-16 09:20:06 EDT
Here's a backtrace when using the dotNET style at the time of the crash:

(gdb) bt
#0  0x40007a71 in do_lookup () from /lib/ld-linux.so.2
#1  0x40006816 in _dl_lookup_symbol_internal () from /lib/ld-linux.so.2
#2  0x40009fbe in fixup () from /lib/ld-linux.so.2
#3  0x4000a190 in _dl_runtime_resolve () from /lib/ld-linux.so.2
#4  0x40256e67 in QApplication::~QApplication() ()
   from /usr/lib/qt-3.0.5/lib/libqt-mt.so.3
#5  0x0809a635 in QGuardedPtr<QWidget>::deref() ()
#6  0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 5 Ngo Than 2002-11-27 09:25:20 EST
Please try qt-3.1.0 in rawhide. I think, it's fixed in this release

Note You need to log in before you can comment on or make changes to this bug.