Bug 75749 - Launcher will not "Run in Terminal"
Launcher will not "Run in Terminal"
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-panel (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-11 16:15 EDT by Gary Fidler
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-08 14:59:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gary Fidler 2002-10-11 16:15:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
A simple script which runs from a launcher with the "Run in Terminal" set, fails
to run with no feedback.  This same script ran this way in 7.3.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create simple script like "echo HELLO WORLD; sleep 5"
2.Create launcher to run script and set "Run in Terminal" option on
3.Hit launcher
	

Actual Results:  Nothing visible

Expected Results:  Terminal window displaying output from script

Additional info:
Comment 1 Havoc Pennington 2002-11-04 17:31:01 EST
Anything in ~/.xsession-errors after the failure?
Comment 2 Havoc Pennington 2003-01-07 23:30:45 EST
Works for me. Sure you didn't do something like forget to chmod +x the script?
Comment 3 Gary Fidler 2003-01-08 12:00:23 EST
A script which works with "Run in terminal" unchecked, will not run with it
checked.  Security is not the issue.

The following error appears in ~/.xsession-errors when "Run in terminal" is checked:

Option --execute/-x requires specifying the command to run on the rest of the
command line
Comment 4 Havoc Pennington 2003-01-08 14:59:49 EST
It definitely works in rawhide, I just tested with a fresh Phoebe install.

Note You need to log in before you can comment on or make changes to this bug.