Bug 7575 - using man won't take you back to the prompt
using man won't take you back to the prompt
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
6.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-03 21:05 EST by jay
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-12-08 10:06:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jay 1999-12-03 21:05:46 EST
In a terminal session, using man
i.e.
[root@localhost /root]# man semop

You get the man page to look at, and space bar will take you down a page at
a time like normal.  But when you get to the end you can't get your prompt
back by hitting enter  or space.  It just beeps.  Then if you crtl-Z you
get the prompt back, but you will have two orphaned processes out there
from your man command.

i.e.
[root@localhost /root]# ps -ef|grep man

now you have to manually kill them to remove them.  This can't be intended.
It must be a bug.
Please help.
Comment 1 Riley H Williams 1999-12-04 10:54:59 EST
This sounds like you're used to the man command on Solaris and similar systems
that use the `more` command as the pager. Under Linux, the `less` command is
usually used as the pager, and the behaviour you quote is the standard (and
documented) behaviour of the said command.

The correct way to exit ANY session using the `less` command, including those
created by `man` using `less` as its pager, is to type 'q' to quit less.

If you prefer to use `more` as your pager, just set the environment variable
MANPAGER to have 'more' as its value, and ensure it is exported. How you do that
depends on what shell you prefer to use.

------- Email Received From  "Jay H. Lang" <jay@tpmq-experts.com> 12/08/99 10:15 -------

Note You need to log in before you can comment on or make changes to this bug.