Bug 757559 - [abrt] tumbler-0.1.22-4.fc16: __libc_message: Process /usr/lib64/tumbler-1/tumblerd was killed by signal 6 (SIGABRT)
[abrt] tumbler-0.1.22-4.fc16: __libc_message: Process /usr/lib64/tumbler-1/tu...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: tumbler (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:ab554ff55dc07c5228a28772554...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-27 14:36 EST by Raphael Groner
Modified: 2011-12-13 16:56 EST (History)
4 users (show)

See Also:
Fixed In Version: tumbler-0.1.23-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-13 16:56:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: event_log (20.99 KB, text/plain)
2011-11-27 14:36 EST, Raphael Groner
no flags Details
File: build_ids (2.08 KB, text/plain)
2011-11-27 14:36 EST, Raphael Groner
no flags Details
File: dso_list (5.05 KB, text/plain)
2011-11-27 14:37 EST, Raphael Groner
no flags Details
File: maps (22.41 KB, text/plain)
2011-11-27 14:37 EST, Raphael Groner
no flags Details
File: backtrace (14.89 KB, text/plain)
2011-11-27 14:37 EST, Raphael Groner
no flags Details
upstream patch for png issue (863 bytes, text/plain)
2011-12-03 06:51 EST, Raphael Groner
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 8041 None None None Never

  None (edit)
Description Raphael Groner 2011-11-27 14:36:52 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/lib64/tumbler-1/tumblerd
comment:        change directory in Thunar, then crash report
crash_function: __libc_message
executable:     /usr/lib64/tumbler-1/tumblerd
kernel:         3.1.2-1.fc16.x86_64
pid:            13483
pwd:            /
reason:         Process /usr/lib64/tumbler-1/tumblerd was killed by signal 6 (SIGABRT)
time:           So 27 Nov 2011 19:48:05 CET
uid:            1000
username:       raphael
var_log_messages: Nov 27 19:48:05 schlebby abrt[13499]: Saved core dump of pid 13483 (/usr/lib64/tumbler-1/tumblerd) to /var/spool/abrt/ccpp-2011-11-27-19:48:05-13483 (29659136 bytes)

backtrace:      Text file, 15246 bytes
build_ids:      Text file, 2132 bytes
dso_list:       Text file, 5170 bytes
event_log:      Text file, 21498 bytes
maps:           Text file, 22944 bytes

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-1DGU2j2ST3,guid=c02515412531337036ae68ac000036cc
:XDG_SESSION_COOKIE=8dca402f6a5fea54dc4099400000000f-1322417191.215727-827065747
:XDG_RUNTIME_DIR=/run/user/raphael
:DISPLAY=:0
:'DESKTOP_SESSION=Xfce Session'
:LC_MESSAGES=de_DE.UTF-8
:PATH=/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin
:XDG_VTNR=1
:LANGUAGE=de_DE.UTF-8
:XDG_SESSION_ID=7
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-1DGU2j2ST3,guid=c02515412531337036ae68ac000036cc
:XDG_SEAT=seat0
:XAUTHORITY=/home/raphael/.Xauthority
:USER=raphael
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=11505
:SYSFONT=latarcyrheb-sun16
:SHLVL=1
:PWD=/home/raphael
:BOOT_IMAGE=/boot/vmlinuz-3.1.2-1.fc16.x86_64
:GNOME_KEYRING_CONTROL=/tmp/keyring-meHKOj
:LANG=de_DE.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=raphael
:HOME=/home/raphael
:KEYTABLE=de-latin1-nodeadkeys
Comment 1 Raphael Groner 2011-11-27 14:36:56 EST
Created attachment 537223 [details]
File: event_log
Comment 2 Raphael Groner 2011-11-27 14:36:58 EST
Created attachment 537224 [details]
File: build_ids
Comment 3 Raphael Groner 2011-11-27 14:37:01 EST
Created attachment 537225 [details]
File: dso_list
Comment 4 Raphael Groner 2011-11-27 14:37:04 EST
Created attachment 537226 [details]
File: maps
Comment 5 Raphael Groner 2011-11-27 14:37:07 EST
Created attachment 537227 [details]
File: backtrace
Comment 6 Raphael Groner 2011-11-27 14:41:21 EST
Can't upload 'coredump', it's too large (29659136 bytes)
Comment 7 Raphael Groner 2011-11-27 14:46:35 EST
Package: tumbler-0.1.22-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
tumbler crashes randomly
Comment 8 Raphael Groner 2011-11-27 14:50:55 EST
Package: tumbler-0.1.22-4.fc16
Architecture: x86_64
OS Release: Fedora release 16 (Verne)

Comment
-----
I have deleted a folder, then abrt reported the crash.
Comment 9 Raphael Groner 2011-11-27 16:13:15 EST
Reassigning to libpng, due to backtrace ...

#6  0x000000344361c522 in png_default_error (error_message=0x3443621188 "Read Error", png_ptr=0x7fd5f800a030) at pngerror.c:296
No locals.
#7  png_error (png_ptr=0x7fd5f800a030, error_message=0x3443621188 "Read Error") at pngerror.c:84
        msg = "\000\000\000\000\000\000\000\000\240\377\377\377\377\377\377\377"
#8  0x0000003443611b1d in png_read_info (png_ptr=0x7fd5f800a030, info_ptr=0x7fd5f8001480) at pngread.c:367
        num_checked = 0
        num_to_check = 8
Comment 10 Tom Lane 2011-11-27 17:56:49 EST
You've apparently got a corrupted png file, and a quick look at xdg_cache_cache_read_thumbnail_info shows that it contains no provision whatsoever for error handling.  libpng is trying to return control via longjmp after an error, but there has been no setjmp call, so the longjmp call crashes.  This is not a libpng bug; it is failure on the caller's part to pay any attention to the libpng API specification.
Comment 11 Raphael Groner 2011-11-28 05:30:04 EST
(In reply to comment #10)
Tim, thanks for your analysis. Upstream has been contacted about my report.
Comment 12 Christoph Wickert 2011-11-28 12:53:52 EST
libc debuginfo is missing. Please run

$ debuginfo-install glibc

and regenerate the backtrace. Thanks!
Comment 13 Raphael Groner 2011-12-03 06:51:44 EST
Created attachment 539971 [details]
upstream patch for png issue

This patch is from upstream.
Comment 14 Christoph Wickert 2011-12-03 07:11:21 EST
Please add the upstream bug as external reference.
Comment 15 Raphael Groner 2011-12-03 07:33:09 EST
(In reply to comment #14)
> Please add the upstream bug as external reference.
I am not quite sure, if it's reported upstream. 

Thought, there's some discussion on the mailing list.
http://mail.xfce.org/pipermail/xfce4-dev/2011-December/029394.html

Maybe, is this a dup of bug #742733 ?
Comment 16 Fedora Update System 2011-12-09 16:53:42 EST
tumbler-0.1.23-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/tumbler-0.1.23-1.fc16
Comment 17 Fedora Update System 2011-12-11 16:52:11 EST
Package tumbler-0.1.23-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tumbler-0.1.23-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-16969/tumbler-0.1.23-1.fc16
then log in and leave karma (feedback).
Comment 18 Fedora Update System 2011-12-13 16:56:02 EST
tumbler-0.1.23-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.