Bug 757560 - [abrt] gnome-shell-3.2.1-2.fc16: magazine_chain_pop_head: Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
[abrt] gnome-shell-3.2.1-2.fc16: magazine_chain_pop_head: Process /usr/bin/gn...
Status: CLOSED DUPLICATE of bug 768143
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
abrt_hash:10767b98fd716440110969e18b1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-11-27 14:46 EST by Steve Barnsley
Modified: 2011-12-15 16:52 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-15 16:52:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (20.36 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: build_ids (6.45 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: smolt_data (3.28 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: xsession_errors (3.49 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: var_log_messages (6.76 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: maps (78.05 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details
File: backtrace (88.41 KB, text/plain)
2011-11-27 14:46 EST, Steve Barnsley
no flags Details

  None (edit)
Description Steve Barnsley 2011-11-27 14:46:18 EST
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        /usr/bin/gnome-shell
comment:        Seems to happen randomly when using the mouse to switch to the activities screen (pointer to top left of screen).  Started happening after I installed the AMD Catalyst driver, but that could be a coincidence.
crash_function: magazine_chain_pop_head
executable:     /usr/bin/gnome-shell
kernel:         3.1.2-1.fc16.x86_64
pid:            16865
pwd:            /home/sbarns
reason:         Process /usr/bin/gnome-shell was killed by signal 11 (SIGSEGV)
time:           Sun 27 Nov 2011 02:18:54 PM EST
uid:            1000
username:       sbarns

backtrace:      Text file, 90534 bytes
build_ids:      Text file, 6603 bytes
dso_list:       Text file, 20847 bytes
maps:           Text file, 79928 bytes
smolt_data:     Text file, 3361 bytes
var_log_messages: Text file, 6926 bytes
xsession_errors: Text file, 3569 bytes

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=coolneshie
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:XDG_SESSION_COOKIE=bc9303ce1798cc7e31c4fb8a00000019-1322417308.737092-1496185283
:GNOME_KEYRING_CONTROL=/tmp/keyring-2xHhfJ
:IMSETTINGS_MODULE=none
:USER=sbarns
:USERNAME=sbarns
:MAIL=/var/spool/mail/sbarns
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/sbarns/.local/bin:/home/sbarns/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/sbarns
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:GNOME_KEYRING_PID=1690
:LANG=en_US.UTF-8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/sbarns
:XDG_SEAT=seat0
:SHLVL=1
:LOGNAME=sbarns
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-7m3pxZsXW6,guid=b354461bea354529ef22a5d400000064
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/sbarns
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-sbarns-xfOIB8/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1697,unix/unix:/tmp/.ICE-unix/1697
:GPG_AGENT_INFO=/tmp/keyring-2xHhfJ/gpg:0:1
:SSH_AUTH_SOCK=/tmp/keyring-2xHhfJ/ssh
:DESKTOP_AUTOSTART_ID=10a38de90a27a495e5132241731079968400000016970000
Comment 1 Steve Barnsley 2011-11-27 14:46:22 EST
Created attachment 537228 [details]
File: dso_list
Comment 2 Steve Barnsley 2011-11-27 14:46:23 EST
Created attachment 537229 [details]
File: build_ids
Comment 3 Steve Barnsley 2011-11-27 14:46:25 EST
Created attachment 537230 [details]
File: smolt_data
Comment 4 Steve Barnsley 2011-11-27 14:46:26 EST
Created attachment 537231 [details]
File: xsession_errors
Comment 5 Steve Barnsley 2011-11-27 14:46:28 EST
Created attachment 537232 [details]
File: var_log_messages
Comment 6 Steve Barnsley 2011-11-27 14:46:30 EST
Created attachment 537233 [details]
File: maps
Comment 7 Steve Barnsley 2011-11-27 14:46:31 EST
Created attachment 537234 [details]
File: backtrace
Comment 8 Steve Barnsley 2011-11-29 10:55:40 EST
The problem seems to occur when running KDE applications, specifically kate but maybe others also, under gnome shell.  The shell keeps crashing, the display flickers when switching windows and the screen doesn't paint correctly (partial windows) when returning from the activities view.
Comment 9 Steve Barnsley 2011-11-29 11:58:26 EST
The problem is caused by having the kwalletmanager icon in the notification area.  If the icon is present the whole window/screen management of the shell goes to hell and the shell periodically crashes.  Close the kwalletmanager icon and everything runs as smooth as silk.
Comment 10 Owen Taylor 2011-12-15 16:52:40 EST

*** This bug has been marked as a duplicate of bug 768143 ***

Note You need to log in before you can comment on or make changes to this bug.