Bug 75758 - Permissions problem with kscd and CDDB
Summary: Permissions problem with kscd and CDDB
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdemultimedia   
(Show other bugs)
Version: 8.0
Hardware: i586 Linux
medium
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-10-11 21:28 UTC by Need Real Name
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-10-11 21:28:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-10-11 21:28:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2b) Gecko/20020922

Description of problem:
Installed RH8 with KDE and development options; KDE is default desktop.    Users
do not have write permission by default to the directory that kscd uses as its
local CDDB; this causes annoying error messages to be displayed every time an CD
is inserted / remote CDDB is queried because kscd tries to write CDDB
information to local database.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start RH8 with KDE as the default desktop.
2. Insert an audio CD.

Actual Results:  Error message returned:

"Unable to write to file:
/usr/share/apps/kscd/cddb/rock/c20ce30c
Please check your permissions and make your category directories exist.[sic]"

Expected Results:  Dialog should have not been displayed; CDDB information
should have been written to local filesystem.

Additional info:

Comment 1 Ngo Than 2002-10-16 15:19:52 UTC
That's not a bug. The normal users don't have write permisson in
/usr/share/apps/kscd/cddb. If you start it as a normal users please set the
freedb Base Directory to your home e.g. /home/foo/.kde/share/apps/kscd.



Note You need to log in before you can comment on or make changes to this bug.