Bug 757648 - [abrt] remmina-0.9.3-3.fc16: magazine_chain_pop_head: Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
Summary: [abrt] remmina-0.9.3-3.fc16: magazine_chain_pop_head: Process /usr/bin/remmin...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: remmina
Version: 16
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Christoph Wickert
QA Contact: Fedora Extras Quality Assurance
URL: https://sourceforge.net/tracker/?func...
Whiteboard: abrt_hash:197a7beb482942bf27a010a8c00...
: 757707 766187 (view as bug list)
Depends On: 766197
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-11-28 08:57 UTC by Wim ten Have
Modified: 2012-01-16 02:17 UTC (History)
3 users (show)

Fixed In Version: libvncserver-0.9.8.2-2.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-07 22:56:05 UTC


Attachments (Terms of Use)
File: build_ids (3.60 KB, text/plain)
2011-11-28 08:57 UTC, Wim ten Have
no flags Details
File: environ (2.68 KB, text/plain)
2011-11-28 08:57 UTC, Wim ten Have
no flags Details
File: smolt_data (3.21 KB, text/plain)
2011-11-28 08:58 UTC, Wim ten Have
no flags Details
File: maps (48.51 KB, text/plain)
2011-11-28 08:58 UTC, Wim ten Have
no flags Details
File: backtrace (40.19 KB, text/plain)
2011-11-28 08:58 UTC, Wim ten Have
no flags Details

Description Wim ten Have 2011-11-28 08:57:54 UTC
libreport version: 2.0.7
abrt_version:   2.0.6
backtrace_rating: 4
cmdline:        remmina
crash_function: magazine_chain_pop_head
executable:     /usr/bin/remmina
kernel:         3.1.2-1.fc16.x86_64
pid:            1989
pwd:            /home/wtenhave
reason:         Process /usr/bin/remmina was killed by signal 11 (SIGSEGV)
time:           Mon 28 Nov 2011 09:54:43 AM CET
uid:            500
username:       wtenhave

backtrace:      Text file, 41151 bytes
build_ids:      Text file, 3690 bytes
environ:        Text file, 2747 bytes
maps:           Text file, 49679 bytes
smolt_data:     Text file, 3282 bytes

dso_list:
:/usr/lib64/gtk-2.0/2.10.0/engines/libxfce.so gtk-xfce-engine-2.8.1-1.fc16.x86_64 (Fedora Project) 1321909308
:/usr/share/icons/hicolor/icon-theme.cache hicolor-icon-theme-0.12-3.fc16.noarch (Fedora Project) 1321908254
:/usr/lib64/remmina/plugins/remmina-plugin-telepathy.so remmina-plugins-telepathy-0.9.2-2.fc15.x86_64 (Fedora Project) 1321982158
:/usr/lib64/remmina/plugins/remmina-plugin-vnc.so remmina-plugins-vnc-0.9.2-2.fc15.x86_64 (Fedora Project) 1321982158
:/usr/share/icons/gnome/icon-theme.cache gnome-icon-theme-3.2.1.2-1.fc16.noarch (Fedora Project) 1321908257
:/usr/lib64/remmina/plugins/remmina-plugin-rdp.so remmina-plugins-rdp-0.9.2-2.fc15.x86_64 (Fedora Project) 1321982157
:/usr/lib/locale/locale-archive glibc-common-2.14.90-19.x86_64 (Fedora Project) 1322419946
:/usr/lib64/remmina/plugins/remmina-plugin-xdmcp.so remmina-plugins-xdmcp-0.9.2-2.fc15.x86_64 (Fedora Project) 1321982158
:/lib64/libnss_dns-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322419950
:/usr/lib64/remmina/plugins/remmina-plugin-nx.so remmina-plugins-nx-0.9.2-2.fc15.x86_64 (Fedora Project) 1321982158
:/usr/share/fonts/dejavu/DejaVuSans-ExtraLight.ttf dejavu-sans-fonts-2.33-1.fc16.noarch (Fedora Project) 1321908243
:/usr/lib64/libminilzo.so.0 lzo-minilzo-2.06-1.fc16.x86_64 (Fedora Project) 1321911641
:/usr/share/fonts/dejavu/DejaVuSansMono.ttf dejavu-sans-mono-fonts-2.33-1.fc16.noarch (Fedora Project) 1321908244
:/usr/lib64/gtk-2.0/2.10.0/immodules/im-ibus.so ibus-gtk2-1.4.0-10.fc16.x86_64 (Fedora Project) 1321908449
:/usr/share/icons/Mist/icon-theme.cache gnome-themes-2.32.0-7.fc16.noarch (Fedora Project) 1321908417
:/usr/lib64/libvncclient.so.0.0.0 libvncserver-0.9.7-5.fc15.x86_64 (Fedora Project) 1321911642
:/lib64/libnss_files-2.14.90.so glibc-2.14.90-19.x86_64 (Fedora Project) 1322419950
:/usr/lib64/gio/modules/libgvfsdbus.so gvfs-1.10.1-2.fc16.x86_64 (Fedora Project) 1321908336
:/lib64/libnss_mdns4_minimal.so.2 nss-mdns-0.10-9.fc15.x86_64 (Fedora Project) 1321908497

var_log_messages:
:Nov 28 09:54:43 Wim-fc kernel: [ 5808.668342] remmina[2611]: segfault at 1 ip 00000034fb45ff35 sp 00007f314b75e710 error 4 in libglib-2.0.so.0.3000.1.#prelink#.bl7PhV (deleted)[34fb400000+11e000]
:Nov 28 09:54:43 Wim-fc abrt[16093]: File '/usr/bin/remmina' seems to be deleted
:Nov 28 09:54:43 Wim-fc abrt[16093]: Saved core dump of pid 1989 (/usr/bin/remmina) to /var/spool/abrt/ccpp-2011-11-28-09:54:43-1989 (100016128 bytes)

Comment 1 Wim ten Have 2011-11-28 08:57:57 UTC
Created attachment 537398 [details]
File: build_ids

Comment 2 Wim ten Have 2011-11-28 08:57:59 UTC
Created attachment 537399 [details]
File: environ

Comment 3 Wim ten Have 2011-11-28 08:58:00 UTC
Created attachment 537400 [details]
File: smolt_data

Comment 4 Wim ten Have 2011-11-28 08:58:02 UTC
Created attachment 537401 [details]
File: maps

Comment 5 Wim ten Have 2011-11-28 08:58:04 UTC
Created attachment 537402 [details]
File: backtrace

Comment 6 Christoph Wickert 2011-11-28 09:20:24 UTC
Thanks for submitting this crash report.

What did you do when the crash occurred? Are you able to reproduce the crash reliably?

Comment 7 Christoph Wickert 2011-11-28 13:34:11 UTC
*** Bug 757707 has been marked as a duplicate of this bug. ***

Comment 8 Christoph Wickert 2011-12-10 22:22:06 UTC
*** Bug 766187 has been marked as a duplicate of this bug. ***

Comment 9 Christoph Wickert 2011-12-10 22:23:23 UTC
Wim, you have now filed the same bug 3 times bug still did not respond to my questions. Can you please do it now?

Comment 10 Wim ten Have 2011-12-10 22:39:48 UTC
Hi Christoph,

I am sorry that i didn't immediately gave response on your "Comment 6" questioned action.  I use remmina a lot usually have an approx of 7 remote desktops around which vary from VNC (remote linux xfce/gnome desktops) to RDP (windows server).  I have no specific way of reproducing the problem.  Only thing i notice is a sudden disappearance of my connections and remmina process (with occasional a full hang of remmina process).  The problem never manifested prior my upgrade to F16.  Prior to F16 i was running F14.  The problem under F16 happens from any environment KDE (default for me) but i also hold encounters under Xfce or GNOME.
I wish i could give you a way to reproduce.  I notice the problem most times when i start entering data ... but i've also seen the problem happen when all sessions were idle.  I must say that there is a lot of activity within my desktops.  Mostly xterms running monitoring all kind of log activity and compiles sessions reporting compile statements.

If you like me to perform specific operations (flags/debug variations) then please let me know.  My ability to work largely depends on the operational stability of 'remmina'.

I am sorry for the frequent reports of its SEGV crashes.

Waiting for you action/prompt.

Regards,
-- Wim ten Have.

Comment 11 Christoph Wickert 2011-12-11 19:48:23 UTC
Thanks for your feedback.

I have added the relevant info to a similar bug I already filed against remmina 0.7.5 at https://sourceforge.net/tracker/?func=detail&atid=1181674&aid=3062058&group_id=278330

I am currently waiting for an updated libvncserver (bug 766197) and then I will do a rebuild of remmina.

Comment 12 Fedora Update System 2011-12-31 11:36:53 UTC
libvncserver-0.9.8.2-2.fc16,remmina-plugins-0.9.2-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/libvncserver-0.9.8.2-2.fc16,remmina-plugins-0.9.2-4.fc16

Comment 13 Fedora Update System 2011-12-31 11:38:04 UTC
libvncserver-0.9.8.2-2.fc15,remmina-plugins-0.9.2-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/libvncserver-0.9.8.2-2.fc15,remmina-plugins-0.9.2-4.fc15

Comment 14 Fedora Update System 2011-12-31 20:26:41 UTC
Package libvncserver-0.9.8.2-2.fc15, remmina-plugins-0.9.2-4.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libvncserver-0.9.8.2-2.fc15 remmina-plugins-0.9.2-4.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-17599/libvncserver-0.9.8.2-2.fc15,remmina-plugins-0.9.2-4.fc15
then log in and leave karma (feedback).

Comment 15 Fedora Update System 2012-01-07 22:56:05 UTC
libvncserver-0.9.8.2-2.fc16, remmina-plugins-0.9.2-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2012-01-16 02:17:31 UTC
libvncserver-0.9.8.2-2.fc15, remmina-plugins-0.9.2-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.