Bug 757711 - Spacewalk-repo-sync could be started with no repository available.
Spacewalk-repo-sync could be started with no repository available.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: WebUI (Show other bugs)
541
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Tomas Lestach
Jiří Mikulka
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2011-11-28 08:21 EST by Dimitar Yordanov
Modified: 2014-10-06 09:46 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:55:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dimitar Yordanov 2011-11-28 08:21:06 EST
Description of problem:

Spacewalk-repo-sync  could be started for a Custom channel even if there is no Yum repository associated with the channel. 

Version-Release number of selected component (if applicable):
spacewalk-java-1.2.39-108.el6sat.noarch

How reproducible:
100%

Steps to Reproduce:
1. Channels -> Manage Software Channels -> create new channel
2. Channels -> Manage Software Channels -> Custom Channel -> Repositories -> Sync
3. In "Repository" section you should see:
    No repositories are currently associated with this channel.
  
4. Press button  "Sync Now"

Actual results:
1. Message on WebUI
Repository sync scheduled for Name custom_chann_sync_repo_sun27nov2011_09_35_55_11138.

2. Logs : /var/log/rhn/rhn_taskomatic_daemon.log

INFO   | jvm 1    | 2011/11/28 14:04:36 | 2011-11-28 14:04:36,528 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.manager.satellite.SystemCommandExecutor - Error encountered executing (args=[/usr/bin/spacewalk-repo-sync, --channel, custom_chann_sync_repo_sun27nov2011_09_35_55_11138, --type, yum])
INFO   | jvm 1    | 2011/11/28 14:04:36 | 2011-11-28 14:04:36,528 [DefaultQuartzScheduler_Worker-7] ERROR com.redhat.rhn.manager.satellite.SystemCommandExecutor - Error message from process: Channel has no URL associated

Expected results:
1. Warning Massage on Web UI
2. spacewalk-repo-sync is not started.

Additional info:

I guess the problem could be reproduced via API as well. (Not tested yet)
Comment 1 Tomas Lestach 2012-07-23 11:22:19 EDT
spacewalk.git: ed0d7452516b3a6be4311a93db2060856b00dbf5
Comment 4 Clifford Perry 2013-10-01 17:55:17 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.